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If you’re reading this guide, it’s because you’ve 

joined—or are thinking of joining—a growing group 

of QuarkXPress users who have discovered the many 

benefits of using Adobe® InDesign® CS5 software. InDesign 

is an immensely powerful page layout program, with 

extraordinary typographic capabilities, innovative graphics 

handling and page layout features, extensive productivity 

tools, versatile long document and printing features, 

support for creating interactive documents, and expansive 

automation capabilities.

This booklet was created specifi-
cally to help users of QuarkXPress 
version 3, 4, 5, or 6 make the 
switch to InDesign as quickly and 
smoothly as possible.

If you’re a long-time QuarkXPress 
user, you’ll find that there are 
many similarities between the 
two programs—for example, they 
both make use of text and graphic 
frames, pasteboards around 
spreads, and master pages.

However, there are some important 
differences between QuarkXPress 
and InDesign to adjust to. Don’t 
worry—this booklet explains the 

key differences between these two 
programs, and it also introduces 
you to powerful features available 
only in InDesign.

If you need more step-by-step 
information, refer to InDesign 
Help, which is accessible from 
within the application. Additionally, 
there are many Adobe and third-
party resources to help you learn 
InDesign. See “InDesign CS5 
resources” on page 56.

If you’re familiar with other Adobe 
graphics applications, such as 
Adobe Photoshop® or Adobe 
Illustrator®, your switch to InDesign 

will be even easier. All Adobe 
Creative Suite® applications share 
common commands, panels, and 
keyboard shortcuts, so if you’re 
familiar with one program, learning 
the others is easy.

Top 10 reasons InDesign is 
better than QuarkXPress
Before we get into the differences 
between the two programs, let’s 
take a quick look at 10 reasons why 
InDesign is the better program.

1. Creative Suite integration:� 
Effortlessly work with Photoshop 
and Illustrator files in your layouts, 
including 3D or layered Photoshop 
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artwork. Open your layouts in 
Adobe Flash® CS5 Professional. 
Export content as XHTML for use in 
Adobe Dreamweaver®. And set up 
better editorial workflows through 
Adobe InCopy® integration.

2. Collaboration:� InDesign lets you 
collaborate with colleagues and 
clients, allowing you to share your 
screen for real-time discussions.

3. Typography:� With its rich 
OpenType® support and features 
such as Optical Kerning, Margin 
Alignment, and the Paragraph 
Composer, InDesign is the clear 
choice for high-quality typesetting.

4. Customizable workspace:� 
When you customize your work-
space, you become more efficient. 
InDesign offers a wide variety of 
customizable options, including 
tabbed documents, tasked-based 
workspaces, editable keyboard 
shortcuts, and even which menu 
commands are visible.

5. Production:� InDesign stream-
lines your production tasks. The 
customizable Preflight panel 
checks your layout for poten-
tial errors while you work. Plus, 
features such as Smart Guides, 

High Quality Display mode, and 
Separations Preview boost effi-
ciency and reduce proofing cycles.

6. True PDF support:� Built from the 
ground up to support international 
standards, InDesign can produce 
PDF files better and faster than 
QuarkXPress.

7. Creative effects:� You can apply 
Photoshop effects (such as drop 
shadows, embossing, and feather-
ing) to any object on your page, 
including text, images, and vector 
graphics. Plus, InDesign supports 
true Photoshop and Illustrator 
transparency, saving you time and 
letting you unleash your creativity.

8. Long documents:� If you work 
with long text documents, you 
need powerful InDesign text fea-
tures such as conditional text, 
cross-references, GREP styles, and 
automatic numbered lists.

9. File management:� The Links 
panel in InDesign is second to none 
in its ability to help you manage 
your linked graphics and text files.

10. Cross-media publishing:� 
Designers today must publish 
across several media, including PDF, 

SWF, and HTML. InDesign gives you 
tools to repurpose your content 
and create engaging interactive 
documents, no matter where your 
audience wants to view them.

Migration strategies
Of course, to become more effi-
cient and productive requires 
that you learn new features and 
sometimes even new workflows. 
Remember that it will likely take 
a little time to become as profi-
cient in InDesign as you were in 
QuarkXPress. However, the ben-
efits far outweigh this temporary 
learning curve.

If you’re in a large workgroup that 
is migrating to InDesign, you might 
consider first training a core group 
of users who can become informal 
trainers over time and then train 
everyone else.

This document should help you and 
your colleagues get up to speed 
quickly in InDesign. Soon, you’ll be 
creating documents with the skill 
and confidence you’ve acquired 
as a QuarkXPress user. Even bet-
ter, you’ll quickly learn how to use 
all of the InDesign features you’ve 
never had before. And your layouts 
will never be the same.
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Learning feature names
Many of the terms in InDesign CS5 menus, dialog boxes, and panels 
are identical to and have the same meanings as terms used in QuarkXPress. 
For example, words like page, book, library, kerning, leading, horizontal 
scale, group/ungroup, lock/unlock, and pasteboard have essentially the 
same meaning in both programs. In some cases, the two programs use 
different terms for the same thing. Once you understand the difference in 
terms, you’re likely to find that associated concepts are quite similar. Here 
are some key terms that differ between QuarkXPress and InDesign.

QuarkXPress term | InDesign term

Box | Frame

QuarkXPress has picture boxes, text boxes, and boxes 
with no content, while InDesign has graphics frames, text 
frames, and unassigned frames.

Item menu | Object menu

In QuarkXPress, you control boxes and lines in the Item 
menu; in InDesign, it’s the Object menu.

Item tool | Selection tool

You use the Selection tool in InDesign (called the Item 
tool in QuarkXPress) to select objects, move 
frames and their contents, and crop the con-
tents of a graphics frame.

Content tool | Direct Selection and Type Tools

In QuarkXPress, you use the Content tool when you want 
to move a picture within a picture box or modify text 
within a text box. In InDesign, you can enter or format 

text with the Type tool, or click and 
drag the Type tool to create a new text 
frame. To move a graphic within its 

frame, choose the Selection tool, place the cursor over the 
image, and drag the round Content Grabber that appears 
in the center of the graphic. You can also use the Direct 
Selection tool to move a graphic within its frame, as well 
as to reshape the frame by dragging any of its anchor 
points or line segments.

Measurements palette | Control panel

In InDesign, the Control panel (Window > Control) is 
similar to the Measurements palette in QuarkXPress. 
The Control panel is context-sensitive, which means that 
the controls displayed in the panel depend on the type of 
object selected, as well as the selected tool.

When the Type tool is selected, the Control panel displays 
controls for modifying character or paragraph attributes, 
depending on which of two icons is selected at the left 
of the panel. When table cells are selected, the Control 
panel displays table-formatting controls. When an object 
is selected with the Selection tool, the Control panel dis-
plays object-related controls.
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Control panel: Character options

Control panel: Paragraph options

Control panel: Object options

Control panel: Table options

The Control panel is context-sensitive. The controls it displays 
change depending on the currently selected object and tool. For 
example, when an object is selected with the Selection tool, the 
Control panel lets you scale, rotate, or flip it.

Document Layout palette | Pages panel

The Pages panel in InDesign is very similar to the Docu-
ment Layout palette in QuarkXPress, though the Pages 
panel lets you display and manage your pages in a num-
ber of ways that QuarkXPress does not. For example, 
InDesign shows thumbnails of each page.

Line | Path

Both programs let you create straight or Bezier-curved 
lines (called paths in InDesign). You can place text or 
pictures inside the boundary of these InDesign paths, 
whether they are open paths or closed shapes.

Starburst tool | Polygon tool

While QuarkXPress has a Starburst tool, InDesign has 
a Polygon tool (paired with the Rectangular and Ellipse 
tools in the Tools panel). Double-click the tool to set the 
Number of Sides and Star Inset values.

Get Picture/Get Text; Import | Place

In QuarkXPress, you import text or graphics using 
the Get Picture or Get Text features (called Import in 
QuarkXPress 7 or later). InDesign lets you place graphics 
and text with or without an existing frame. To place text 

or graphics, choose File > Place, locate the file you want, 
and click Open. If an empty frame is selected, the text 
or graphics content will appear in it automatically. If no 
frame is selected, you can click to create a frame and place 
the content into it, or drag to create a frame of a spe-
cific size. For more information, see “Importing text and 
graphics” on page 22.

Note that you can also place multiple files at the same 
time in InDesign, which is a great time-saver.

Background color | Fill

In QuarkXPress, you use the Modify dialog box or the 
Colors panel to apply a background color or blend to 
boxes. In InDesign, you fill objects by selecting the Fill 
icon in the Tools panel or the Swatches panel, and then 
selecting a color, tint, or gradient in the Swatches, Tools, 
Color, or Gradient panel. You can also choose a color 
from the Fill button in the Control panel.

You can change the fill color of any object—including 
frames, selected text, and paths—to a solid color, a tint, a 
gradient, or None (fully transparent). For more informa-
tion, see “Stroke and fill” on page 13.
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Frame | Stroke

QuarkXPress is limited to putting frames around boxes 
and changing line width. With InDesign, you can add a 
stroke to any InDesign object, including a path, frame, or 
selected text, with the Control or the Stroke panel. Then 
apply a color, a tint, or a gradient to the stroke using the 
Swatches, Color, Gradient, Control, or Tools panel.

Runaround | Text Wrap

Both programs let you spec-
ify how text flows around 
an obstructing object. In 
QuarkXPress, you use the 
Runaround dialog box; in 
InDesign, you use the Text 
Wrap panel. For more infor-
mation, see “Text wrap” on 
page 16.

Linking | Threading

In QuarkXPress, you use the Linking and Unlinking 
tools to control text flow through multiple text boxes. In 
InDesign, each text frame has an in port and an out port 
that let you flow text through multiple frames, a process 
called “threading” (see “Text threading” on page 13).

Table tool | Insert Table

To make a table object in QuarkXPress, you must use the 
Table tool. In InDesign, tables are always anchored inside 
text frames. After clicking an insertion point in a text 
frame with the Type tool, you can make a table by choos-
ing Table > Insert Table. For more information on creat-
ing tables, see “Working with tables” on page 28.

H&Js | Hyphenation and Justification

QuarkXPress handles text spacing and hyphenation by 
defining styles in the H&Js dialog box. In InDesign, you 
can change these settings on individual paragraphs using 
the Hyphenation and Justification dialog boxes, found in 
the Paragraph panel menu. You can also edit hyphenation 
and justification values when defining each paragraph 
style in your document.

Color | Swatch

In InDesign, named colors are 
called swatches. A swatch can 
be a solid color, a tint of a solid 
color, a mixed ink swatch (see 
the next page), or a gradient. 
Choose Window > Color > 
Swatches to open the Swatches 
panel, where you can create, 
apply, delete, and load swatches. 
InDesign also has a Color panel 
(Window > Color > Color) that 
lets you mix and apply unnamed colors and,  
optionally, add them to the Swatches panel.

White (color) | Paper (swatch)

In InDesign, the Paper swatch simulates the color of the 
paper on which you’re printing and is analogous to the 
color White in QuarkXPress.

Blend | Gradient

Unlike QuarkXPress, which limits you to two-color 
blends, InDesign lets you include as many colors as you 
want in a gradient, and you can also adjust the midpoint 
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between any two colors in a gradient. For more informa-
tion, see “Creating and applying gradients” on page 39.

Multi-Ink Color | Mixed Ink Swatch

In QuarkXPress, you can combine shades of two or more 
spot or process colors to create a multi-ink color. In  
InDesign, you can combine a spot color with other spot 
and process colors to create a mixed ink swatch. You also 
have the option to combine incremental percentages of 
two colors to create mixed ink groups. To create a mixed 
ink swatch, choose New Mixed Ink Swatch from the 
Swatches panel menu (Window > Color > Swatches).

Save Backward | Export InDesign Markup (IDML)

QuarkXPress lets you save a document that can be 
opened by the previous version of the program. To 
do this in InDesign, choose File > Export, and then 
choose InDesign Markup (IDML) from the Format menu 
(Mac OS) or the Save As Type menu (Windows®). The 
exported file will be given an IDML extension and can be 
opened in the previous version.

Collect For Output | Package

In QuarkXPress, you use the Collect For Output com-
mand to save a copy of a document and its linked files 
in a single folder for handoff to a service provider. In 
InDesign, you choose File > Package. This command also 
offers the option to collect the fonts you have used.

Font Usage | Find Font

To find a list of every font used in a document, you go to 
the Usage dialog box in QuarkXPress. In InDesign, you 
can choose Type > Find Font.

Picture Usage | Links

In QuarkXPress, the Pictures pane 
of the Usage dialog box displays 
information about imported pic-
tures. In InDesign, you manage 
the status of imported graphics 
and text in the Links panel (Win-
dow > Links). You can also obtain 
detailed information about each 
link in the Link Info section of the 
panel, including file type, resolu-
tion, and color space. To edit the 
file in its original application, click 
the Edit Original button  in the 
Links panel.

No Style | Break Link to Style

Each QuarkXPress document has two default paragraph 
styles: No Style and Normal. InDesign documents have 
one: Basic Paragraph Style, which is similar to Normal. To 
remove the link to a paragraph style, select the paragraph, 
and then choose Break Link To Style from the Paragraph 
Style panel menu.

XTensions | Plug-ins

XTensions are software modules that add functionality to 
QuarkXPress. InDesign plug-in modules (developed by 
Adobe and third-party software developers) add features 
to InDesign. Plug-ins are stored in the Plug-Ins folder 
within the InDesign program folder. For a complete list 
of available plug-ins for InDesign, visit www.adobe.com/
products/plugins/indesign.
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Top 10 differences 
you need to understand

When you start using InDesign, you’ll quickly find a number of 
similarities between it and QuarkXPress: Both programs display spreads 
on individual pasteboards; both have standard methods for saving and 
opening documents and templates; each has a “toolbox” and floating panels. 
InDesign was built to be intuitive and easy for QuarkXPress users to learn. 
However, there are some significant differences between the two programs 
that you must understand if you want to be proficient in InDesign.

Modify dialog box replacements

In QuarkXPress, the Modify dialog 
box contains controls for modify-
ing items, and most users open this 
dialog box frequently as they build 
pages. InDesign doesn’t have a com-
parable dialog box. Instead, controls 
for modifying objects are available in 
the Control panel, as well as in other 
panels such as the Swatches, Text 
Wrap, and Stroke panels.

To modify the placement of text 
within a text frame—including num-
ber of columns, text inset values, and 
placement of the first line of text—
choose Object > Text Frame Options.

Frames are frames

InDesign has graphic, text, and unas-
signed frames, similar to those in 
QuarkXPress. You can easily convert 
a frame from one type to another. For 
example, if you select a text frame, 
choose File > Place, and choose an 
image, InDesign changes the frame 
to a graphic frame and replaces any 
text with the placed image.

Similarly, if you click with the Type 
tool on an empty graphic frame or 
unassigned frame, InDesign converts 
it to a text frame. If you prefer that 
InDesign not do this, open the Pref-
erences dialog box (Command+K/
Ctrl+K), choose the Type pane, and 
deselect the Type Tool Converts 
Frames To Text Frames option.

Here are several more facts about 
frames that you should note:

■■ The Rectangle Frame tool creates 
graphic frames; the Rectangle tool 
creates unassigned frames.

■■ Unassigned frames that have a 
fill color of None are “empty,” so 
you can click through them to 
objects behind them. To learn how 
to select objects behind text and 
graphic frames, see “Selection tool 
techniques” on page 36.

■■ Any path can be a frame. For 
example, you can draw an open 
U-shaped path with the Pencil tool 
or the Pen tool, and then place text 
or a graphic inside the shape.
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Selection tool	

Direct Selection tool

Page tool

Gap tool

Type tool, Type On A Path tool

Line tool	

Pen tool, Add Anchor Point tool, Delete Anchor 
Point tool, Convert Direction Point tool

Pencil tool, Smooth tool, Erase tool	

Rectangle Frame tool, Ellipse Frame tool, 
Polygon Frame tool	

Scissors tool	

Free Transform tool, Rotate tool,  
Scale tool, Shear tool	

Eyedropper tool, Measure tool	

Gradient Swatch tool

Gradient Feather tool	

Rectangle tool, Ellipse tool, Polygon tool	

Hand tool	

Zoom tool	

Default Fill And Stroke	

Formatting Affects Container/Text

Apply: None, Color, Gradient

View modes: Normal, Preview, Bleed,  
Slug, Presentation

Note tool	

Fill and Stroke boxes	

Swap Fill And Stroke	

Master page objects

In QuarkXPress, any object on a 
master page can immediately be 
selected and changed on a document 
page. InDesign protects master-page 
objects from accidental changes. 
Master-page objects have dotted, 
rather than solid, edges.

To select a master object on a docu-
ment page, you must override it by 
pressing Shift+Command (Mac OS) 
or Shift+Ctrl (Windows), and then 
clicking the object. You can also 
choose Override All Master Page 
Items from the Pages panel menu.

If you want to prevent a master 
object from being selected on a doc-
ument page, select the object on the 
master page, and then deselect Allow 
Master Item Overrides On Selection 
in the Pages panel menu.

Text leading

InDesign treats leading as a character 
attribute, not a paragraph attribute. 
Leading controls are displayed in the 
Character panel (Type > Character) 
and also in the Control panel when 

Tip:
SELECT A TOOL QUICKLY

You can quickly choose any tool in the 

Tools panel by pressing a single key, 

such as P for the Pen tool or T for the 

Type tool. (Be sure that you don’t have 

an active insertion point in a text frame, 

or you’ll simply type the letter.)
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Click to open 
or close panels  
in the panel dock.

You can choose  
a workspace.

You can change  
the Zoom level.

Click to open  
Adobe Bridge.

Drag this 
handle to 
move the 
Control panel 
elsewhere on 
the screen.

The Application 
Frame hides 
distracting 
elements on 
your desktop.

The Application 
Bar makes 
controls easily 
accessible.

All panels are listed 
in the Window menu.

Live Preflight 
feedback is displayed.

You can navigate 
among your pages.

Search Adobe 
Community Help.

Multiple 
documents 
appear as tabs 
(drag any tab 
to reposition 
or undock it).

While at first glance InDesign may 
appear to be very different from 
QuarkXPress, many of the features 
are actually similar. Take a moment 
to get acquainted with the location 
of panels, menus, and controls in 
the document window below.

Here are some tips for managing 
the panels you’ll be working with:

Document window

■■ Workspaces remember the loca-
tion of each panel onscreen, 
including whether it’s visible or 
hidden. You can choose among 
preset workspaces from the 
Workspace menu on the Applica-
tion Bar, or create your own.

■■ You can dock a panel to the edge 
of your screen by dragging its tab 
to the left or right edge.

■■ When the insertion point is not 
blinking, press Tab to show/hide 
all panels, or Shift+Tab to show/
hide all panels except the Tools 
panel and the Control panel.

■■ Drag the left edge of the dock to 
expand or collapse a stack of  
panels and display icons. When 
you widen a stack, icons and 
labels are displayed.
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the Character Formatting Controls 
icon  is selected at the left side of 
the Control panel. The largest leading 
value on each line in a paragraph sets 
the spacing for that line. 

While this is a more traditional 
approach to leading, it can be 
frustrating to those accustomed 
to the way QuarkXPress works. If 
you prefer that every character in 
a paragraph have the same leading 
value, you can open the Preferences 
dialog box, choose the Type pane, 
and then select the Apply Leading 
To Entire Paragraphs option.

Text threading

You won’t find any tools for link-
ing and unlinking text frames in the 
InDesign Tools panel. That’s because 
linking and unlinking—or threading, 
as it’s called in InDesign—is accom-
plished via the in and out ports on 
text frames.

The in port of a text frame is a 
small square just below the frame’s 
upper left corner; the out port is 
just above the lower right corner. If 
an out port is displayed in red with 
a red plus sign within, it indicates 
there is overset text. For more on 
viewing or editing overset text, see 
“Story Editor” on page 44.

To add a new text frame after an 
existing text frame, select either 
the Selection tool or the Direct 

Selection tool, click the existing 
frame, and then click the frame’s 
out port. A loaded icon is dis-
played. At this point, you can:

■■ Click or drag to create a new text 
frame on your page.

■■ Click within another existing text 
frame to thread to that frame. The 
frame you click may be empty or 
contain text.

Use the same process to add a text 
frame in front of an existing frame, 
except begin by clicking the frame’s 
in port.

To unlink two threaded text frames, 
double-click either the out port of the 
first frame or the in port of the sec-
ond frame. You can see how frames 
are threaded together when the 
Selection tool is selected by choosing 
View > Show Text Threads.

Stroke and fill

QuarkXPress limits the kinds of 
objects to which you can apply a 
Background Color or Frame. In 
InDesign, you can select any text, 
path, or frame, and apply a solid, 
tint, or gradient fill or stroke color 
from the Fill or Stroke button in the 
Control panel. Alternatively, you can 
choose the Fill or Stroke icon at the 
bottom of the Tools panel, or at the 
top of the Swatches or Color panel. 
Then do one of the following:

■■ Click a color swatch in the 
Swatches panel.

■■ Specify a color in the Color panel.

■■ Define a blend from one color to 
another in the Gradient panel.

■■ Choose Apply Color, Apply Gradi-
ent, or Apply None from the Apply 
Color pop-up menu at the bottom 
of the Tools panel.

    Top 10 differences you need to understand  13






The Fill and Stroke buttons in the Control 
panel let you apply solid colors, tints, and 
gradients, even if all other panels are 
closed.

Note that you can apply a color, tint, 
or gradient to the fill or stroke of text 
characters without converting the 
text to outlines. (If you do choose 
Type > Create Outlines, the resulting 
text is no longer editable.)

If you have one or more text frames 
selected with the Selection tool, you 
can apply a fill or stroke to the text 
within each frame by first clicking 
the Formatting Affects Text icon   
in the Tools panel, Swatches panel, 
or Color panel. If instead you select 
the Formatting Affects Container 
icon , the fill or stroke is applied 
to the selected frame rather than to 
the text.

The Default Fill And Stroke icon  
in the Tools panel lets you return the 
Fill and Stroke icons to their default 
settings. The Swap Fill And Stroke 
icon  reverses the colors of the 
stroke and fill icons.

Selecting images versus frames

In QuarkXPress, you must select the 
Content tool before you can modify 
either text or a graphic. InDesign 
doesn’t have a single tool for modify-
ing both text and graphics. Instead, if 
you want to modify a graphic with-
out affecting its frame, choose the 
Selection tool, place the cursor over 
the graphic, and click or drag the cir-
cular Content Grabber. Alternatively, 
you can double-click the frame—if 
it is a text frame, InDesign switches 

to the Type tool and places the text 
cursor where you clicked. If it is a 
graphic frame, InDesign selects the 
graphic inside the frame.

For example, if you want to move an 
image into another frame, click its 
Content Grabber with the Selection 
tool (to select the graphic inside the 
frame), choose Edit > Cut, select the 
destination frame, and choose Edit > 
Paste Into.

Similarly, you can change the color 
of imported black-and-white and 
grayscale graphics (but not of color 
graphics) by first selecting the 
graphic and then clicking a color in 
the Swatches panel. 

The tool you use when scaling or 
resizing a graphic also determines 
the result. For more information on 
scaling, resizing, and cropping, see 

“Working with graphics and frames” 
on page 23.

Ruler guides are objects

To create a ruler guide, click the 
horizontal or vertical ruler, and drag 
the pointer onto a page or the paste-
board. If you release the pointer over 
a page, the guideline extends across 
the page. If you release the pointer 
over the pasteboard, the guideline 
spans the page and pasteboard. You 
can also double-click a ruler to create 
a guideline where you click. (Hold 
down the Shift key while dragging or 
double-clicking to add the guide at 
the nearest ruler tick mark.)

Ruler guides behave much like 
objects you create with the drawing 
tools. You can select a ruler guide by 
clicking it with the Selection, Direct 
Selection, or Position tool, and you 
can select multiple guides by Shift-
clicking or by clicking and dragging 
over two or more guides. 
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Every power user knows that one 
of the best ways to get efficient in 
a program is to learn the keyboard 
and mouse shortcuts. For example, 
most people know that you can 
create a new document by pressing 
Command+N (Mac OS) or Ctrl+N 
(Windows). 

Here’s a handful of the most useful 
shortcuts you should know when 
using InDesign.

However, note that InDesign lets 
you edit any keyboard shortcut, or 
assign a shortcut to any of the sev-
eral hundred features that don’t 
have a default shortcut. To edit or 
assign a custom shortcut, choose 
Edit > Keyboard Shortcuts.

In the Keyboard Shortcuts dialog 
box, you can choose a different set 
(such as Shortcuts For QuarkXPress 
4.0) or define your own set by 
clicking the New Set button.

To see a list of every shortcut in 
InDesign, click the Show Set button 
or see InDesign Help.

Feature Mac OS Windows
Place (text or image) Command+D Ctrl+D
Export Command+E Ctrl+E
General Preferences Command+K Ctrl+K
Add Page Command+Shift+P Ctrl+Shift+P
Paste Without 
Formatting

Command+Shift+V Ctrl+Shift+V

Paste Into Command+Option+V Ctrl+Alt+V
Paste In Place Command+Option+Shift+V Ctrl+Alt+Shift+V
Select All Command+A Ctrl+A
Deselect All Command+Shift+A Ctrl+Shift-A
Undo Command+Z Ctrl+Z
Redo Command+Shift+Z Ctrl+Shift+Z
Show/hide all panels Tab Tab
Jump to Control panel Command+6 Ctrl+6
Toggle Character and 
Paragraph Formatting 
in Control panel

Command+Option+7 Ctrl+Alt+7

Selection tool 1 Esc Esc
Selection tool2 V V
Text Frame Options Command+B Ctrl+B
Story Editor Command+Y Ctrl+Y
Toggle Normal and 
Preview Mode2

W W

Quick Apply Command+Return Ctrl+Enter
Fit Page In Window Command+0 Ctrl+0
Fit Spread In Window Command+Option+0 Ctrl+Alt+0
Show Hidden 
Characters

Command+Option+I Ctrl+Alt+I

Temporary Hand tool Option+spacebar-drag Alt+spacebar-
drag

Preflight panel Command+Option+Shift+F Ctrl+Alt+Shift+F

1Applies only when editing text in a text frame.
2Applies only when not editing text in a text frame.

Top 25 shortcuts you should know
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The Text Wrap panel lets you control how 
text wraps around an object. Here, the text 
wraps around the left side of the image’s 
transparency mask.

You can edit the shape of the text wrap with 
the Direct Selection tool.

You can reposition a selected guide 
by dragging it, using the arrow keys 
on your keyboard, or entering an X 
or Y value in the Control panel. You 
can also delete, lock, cut, copy, or 
paste guides like any other object. 

The Grids & Guides menu (View > 
Grids & Guides) provides several 
commands for showing, hiding,  
locking, and snapping objects to 
gridlines and guidelines.

InDesign also offers Smart Guides, 
which appear automatically as you 
drag, rotate, or resize objects on your 
page. Smart Guides help you align 
and distribute objects by giving you 
real-time feedback about the object 

you’re moving and its relation to 
other objects on the page. You can 
enable or disable Smart Guides by 
choosing View > Grids & Guides > 
Smart Guides.

Text wrap

In QuarkXPress, you use the  
Runaround controls in the Modify 
dialog box to control the flow of text 
around an object; in InDesign, you 
use the Text Wrap panel (Window > 
Text Wrap).

Select an icon at the top of the Text 
Wrap panel to indicate how text 
will flow when the selected object 
overlaps a text frame: No Text Wrap, 
Wrap Around Bounding Box, Wrap 

Tip:
PREVENTING TEXT WRAP

To prevent text in a frame from wrap-

ping around an object with a text wrap, 

select the text frame, choose Object > 

Text Frame Options, and then select 

Ignore Text Wrap.

Around Object Shape, Jump Object, 
or Jump To Next Column.

If you choose Wrap Around Object 
Shape, and the object is a graphic 
with a transparent background, you 
may want to choose Detect Edges, 
Photoshop Path, Alpha Channel, 
or Same As Clipping from the Type 
pop-up menu in the panel. These 
allow the text wrap to flow around 
the nonrectangular graphic.

InDesign normally allows text to 
wrap on both sides of an object. You 
can change this behavior in the Wrap 
To pop-up menu. The options are 
Right Side, Left Side, Both Right & 

The selected object is a native Photoshop 
image with a transparent background. Note 
that the text is on a layer above the image.
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Left Sides, Side Towards Spine, Side 
Away From Spine, and Largest Area. 

While QuarkXPress limits you to 
flowing text around objects placed 
above the text box, text wrap in 
InDesign affects text frames above 
and below an object. However, if 
you prefer InDesign to limit its text 
wrap behavior, open the Preferences 
dialog box, choose the Composition 
pane, and select the Text Wrap Only 
Affects Text Beneath option.

Character, Paragraph, Table, 

and Object styles

Character and paragraph styles are 
great time-savers for text-intensive 
publications like newspapers, books, 

You can choose File > Open in 
InDesign to open documents and 
templates created with QuarkXPress 
or QuarkXPress Passport 3.3–4.11. 

When you open a QuarkXPress file 
in InDesign, a new, untitled docu-
ment is created. InDesign converts 
the original file information to native 
InDesign information. Most objects, 
styles, and colors are translated prop-
erly, but text may reflow differently, 
so proof the results carefully.

Before converting a QuarkXPress 
document, you should store all 
imported picture files in a single 

folder, relink all pictures in the Pic-
tures tab of the Usage dialog box 
(Utilities > Usage > Picture), and 
then use File > Save As to save a 
clean version of the document in 
QuarkXPress. This ensures that all 
links are preserved. 

If your QuarkXPress document does 
not convert, check the original file 
and remove any objects that require 
an XTension; then save and try to 
convert the document again.

QuarkXPress 5.x, 6.x, 7.x, and 8.x files 
are stored in a proprietary format 
that InDesign cannot directly open. 

However, a third-party developer 
called Markzware (www.markzware.
com) offers a conversion utility called 
Q2ID that can convert these files.

Opening a QuarkXPress document 
may be efficient in the short run, 
but it is often better to re-create the 
document, making use of the unique 
features of InDesign, such as based-
on master pages, nested styles, and 
object styles. Another option is to 
export the QuarkXPress file as a PDF 
and place each page of the PDF inside 
the InDesign document as a graphic.

magazines, and catalogs. InDesign 
also includes object styles, which you 
can apply to any InDesign object, 
and table styles and cell styles, which 
make document-wide changes to 
table and cell formatting quickly and 
painlessly.

However, note that character styles 
are handled differently in InDesign 
than in QuarkXPress. You can define 
a character style in InDesign to be 
as specific as you want. For example, 
your character style could be defined 
to apply only italic, ignoring any 
other formatting already applied to 
the text. You could then apply that 
same “italic” character style to text 

set in different fonts and sizes, and it 
would always make it italic—except 
in the case where a font doesn’t have 
an italic style. (InDesign will never 
apply a “fake” italic to text.)

Note that in general you should not 
format an entire paragraph with a 
single character style. Instead, use a 
paragraph style, which applies both 
paragraph and character formatting 
to the selected text.

Character styles also allow for some 
of the most powerful text format-
ting features in InDesign, including 
nested styles, GREP styles, and drop 
cap styles. For more information, see 
“Nested Styles” on page 42.

Opening QuarkXPress files
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Creating a new document
In both QuarkXPress and InDesign, 
choosing File > New > Document 
or pressing Command+N (Mac OS) 
or Ctrl+N (Windows) displays the 
New Document dialog box. The 
controls in these dialog boxes are 
similar, but not identical. Here are a 
few things you should know about 
creating a new InDesign document:

■■ Facing Pages: If you’re creating a 
book or magazine with a left and 
right (verso and recto) page for-
mat, select this option.

■■ Master Text Frame: This is similar 
to the Automatic Text Box option 
in QuarkXPress. While this feature 
is not as important in InDesign as 
it is in QuarkXPress, it is useful if 
you will be using the Smart Text 
Reflow feature, which can add or 
delete pages as you type or edit 
text on your InDesign pages.

■■ The maximum size of an InDesign 
page is 216 x 216 inches (that’s 
an 18-foot or 548-cm square) 
compared to 48 x 48 inches in 
QuarkXPress.

■■ The Page Size menu lists common 
screen resolution sizes—helpful 
when creating documents that 
will be exported to PDF or SWF 
to be viewed onscreen. For all 
intents and purposes, points and 
pixels are equivalent measures.

■■ The Intent menu should match 
the document’s final destina-
tion: Choose Print to create a 
document with CMYK swatches 
and transparency blend mode. 
Choose Web for onscreen, inter-
active documents, because it sets 
your color swatches and transpar-
ency blend mode to RGB and your 
measurements to pixels.

■■ If you later change your mind 
about the final page size, you can 
choose File > Document Setup. 
This also lets you convert a fac-
ing-page document into a single-
sided document, or vice versa. 

■■ You can change a document’s 
margin and column settings by 
choosing Layout > Margins And 
Columns. While QuarkXPress lets 

you adjust margins and columns 
only on a master page, InDesign 
lets you change these settings 
for a master page or one or more 
individual document pages—
depending on what you select in 
the Pages panel.

■■ If your document opens vertically 
(like a wall calendar) instead of 
horizontally, you can later rotate 
one or more spreads by select-
ing them in the Pages panel and 
choosing Rotate Spread View > 
90° CW (or 90° CCW) from the 
Pages panel menu.

■■ Although you can create a sin-
gle document with as many as 
9,999 pages, you’ll probably want 
to use the Book feature (File > 
New > Book) to manage your 
long documents. A book file is a 
collection of InDesign files. You 
can sequentially number pages in 
booked documents, and use the 
Synchronize feature to ensure the 
documents use the same styles, 
color swatches, and master pages.
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You can save any settings you 
choose in the New Document 
dialog box as presets. After 
you create a preset, it’s 
displayed in the Document 
Preset menu in the New 
Document dialog box. 

You can create a new 
document quickly based on 
the last chosen document 
preset by pressing 
Command+Option+N 
(Mac OS) or Ctrl+Alt+N 
(Windows).

You can enter the number of 
pages and the starting page 

number for your new 
document, if you wish, but it 

is optional. You can always 
add or remove pages or 

change page numbers later 
in the Pages panel.

The More Options button displays 
controls for creating bleed and 
slug guides on the pasteboard.

The bleed area is for objects that 
you want to extend all the way to 

the trimline of the printed 
document; the slug area is for 

instructions to the printer, sign-off 
forms, or other information 

related to a document.

You can modify any document preset, 
including the [Default] preset, by choosing 
File > Document Presets > Define.

If your document is destined 
for a CMYK output, such as a 
printing press, choose Print. 

For interactive documents, 
choose Web.

When this link icon is 
selected, InDesign helps 
ensure that all the values in 
that section are the same.

A new facing-pages document begins with a 
right-hand page. If you need to start the 
document with a left-hand page, set the Start 
Page # field to an even number.
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Navigating documents
InDesign offers many of the same methods for document navigation 
you’ve become accustomed to in QuarkXPress. Even better, it includes several 
features that let you navigate more quickly to the page you want to display, 
zoom in more closely on the area you want to work on, and see more clearly 
the objects you want to modify.

Navigating around a page

Besides the scroll bars on the side 
and bottom of each document win-
dow, there are several ways to pan 
around a page, or even from one 
page to another:

■■ The Hand tool lets you adjust the 
visible portion of the page within 
the document window. You can 
temporarily access the Hand tool 
(and scroll the page) by pressing 
Option+spacebar (Mac OS) or 
Alt+spacebar (Windows).

■■ Holding down the mouse button 
with the Hand tool selected for 
about one second invokes the 
Power Zoom mode, zooming out 
to show you the current spread. 
The red rectangle indicates the area 

you will see when you release the 
mouse button. Drag this rectangle 
to a different location or use the 
arrow keys on your keyboard (or 
scroll wheel) to change its size.

You can also zoom in and out by 
choosing one of the magnifica-
tion commands in the View menu, 
using the Zoom tool, or specifying a 
percentage in the Zoom field in the 
Application Bar (if currently visible).

Navigating from page to page

Like QuarkXPress, InDesign pro-
vides a keyboard command—
Command+J (Mac OS) or Ctrl+J 
(Windows)—that lets you quickly 
navigate to a particular page. When 
you use this keyboard shortcut, the 
Go To Page dialog box is displayed. 
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When in Power Zoom mode, the red 
rectangle shows the area that you’ll 
see when you release the mouse 
button. Drag the rectangle to view a 
different area or page. Use the scroll 
wheel or the arrow keys on your 
keyboard to change zoom percentage.

You can click a tab to 
navigate from one 

document to another. 
Drag the tab to separate 

it into its own window.

The Arrange Documents 
widget in the Application 
Bar lets you quickly 
position multiple 
windows onscreen.

The Pages panel can display pages vertically 
(above left) or horizontally (above right), 
which often allows you to see more pages in 
a smaller space. To change the view 
settings, choose Panel Options from the 
panel menu.

When the pointer is within the Pages 
panel, it changes into a grabber 
hand. You can use a mouse wheel, or 
click and drag, to scroll through the 
pages of a document. 

To move to a particular page, 
double-click a page icon in the 
Pages panel (right). To navigate 
within a multipage document, use 
the controls at the bottom left of 
the document window (below).

Type the page or master-page num-
ber you want to display, and then 
click OK or press Return or Enter.

You can also navigate to a different 
page by:

■■ Choosing or entering a page num-
ber in the page number field at the 
bottom of the document window.

■■ Clicking the First Page, Previ-
ous Page, Next Page, or Last Page 
arrows on either side of the page 
number field.

■■ Choosing any of the navigation 
commands in the Layout menu. 
For example, Go Back returns to 
the last page you viewed, much like 
the Back button in a web browser.

■■ Double-clicking page icons in the 
Pages panel (Window > Pages).

■■ Pressing Shift+Page Down to go 
to the next page or Shift+Page Up 
to go to the previous page. In a 
facing-pages document, you can 
instead press Option (Mac OS) 
or Alt (Windows) to navigate one 
spread at a time.

Navigating through windows

If you have more than one document 
window open, you can switch from 
one to another by choosing from 
the Window menu or by pressing 
Command+~ (Mac OS) or Ctrl+Tab 
(Windows).
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When you import text using the Place 
command, you can select Show Import 
Options in the Place dialog box to control 
how formatting is handled. InDesign 
provides many options for preserving and 
removing formatting.

Importing text and graphics
InDesign supports import of all common formats for both text 
and graphics, including RTF, Microsoft Word, Microsoft Excel, TIFF, JPEG, 
PDF, EPS, Buzzword files from Acrobat.com, and even native Photoshop 
and Illustrator files (see “Using native file formats” on page 26). You 
can also import InDesign (INDD) files into InDesign layouts. If you are 
creating a “rich media” PDF file with InDesign, you can import QuickTime, 
AVI, MPEG, and SWF movie files, or AIFF, WAV, and AU sound clips. These 
file formats can be played when you export a document to Adobe PDF.

There are three basic methods for 
importing text and graphics into 
your InDesign document: Copy and 
Paste; choose File > Place; or drag 
and drop files from Adobe Bridge, 
the Mini Bridge panel (Window > 
Mini Bridge), the Mac OS Finder, 
or Windows Explorer into an open 
InDesign document.

Importing text

Copying and pasting plain text 
into InDesign is a useful and quick 
import method, but formatting and 
special characters are often lost in 
the translation. Instead, importing a 
Microsoft Word or Rich Text Format 
(RTF) file using File > Place is often a 
better choice.

InDesign offers robust support for 
both Word and RTF files. When you 
import a Word document or an RTF 
document, you have the option to 
rename styles (in case of a nam-
ing conflict), overwrite an existing 
InDesign style with the Word or RTF 
style, or map a Word or RTF style to 
an existing InDesign style. 

To access these style-mapping 
options, as well as several other 
options, choose File > Place, select 
a Word or RTF file, and then select 
Show Import Options in the Place 
dialog box. When you click Open, 
the Microsoft Word Import Options 
dialog box is displayed.
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To change how an image is cropped, drag 
its circular Content Grabber. A ghosted 
image of the whole graphic appears when 
you drag (not shown here) to help you 
position the image properly.

If the styles in the Word or RTF file 
have names that do not match the 
styles in your InDesign document, 
you can use Customize Style Import 
to map them properly.

When you click OK, InDesign places 
the text into the currently selected 
text frame. If no frame was selected, 
InDesign loads the Place icon ( ):

■■ To flow text manually, move the 
loaded Place icon inside an exist-
ing frame, and then click. The text 
stops flowing at the bottom of 
the frame or the last of a series of 
threaded frames. You can also click 
an empty area to create a new text 
frame that’s the size of the current 
page column. If you click and drag 
the loaded Place icon, you create a 
new frame the size of the rectangle. 

Here’s a quick overview of how to 
resize and crop images:

■■ To scale a frame and its contents, 
hold down Command (Mac OS) 
or Ctrl (Windows) while dragging 
a handle with the Selection tool. 
Add the Shift key to maintain the 
proportions as you resize. 

■■ To scale to a specific width or 
height, replace the X or Y per-
centage value in the Control 
panel with a specific value.

■■ To crop an image inside a frame, 
click the frame with the Selection 
tool and drag one of its side or 
corner handles.

■■ �To move an image inside its 
frame, use the Selection tool to 
drag the Content Grabber, or dou-
ble-click the graphic to select it, 
and then drag the image.

■■ To fit a frame to its content, dou-
ble-click a frame handle or press 
Command+Option+C (Mac OS) 
or Ctrl+Alt+C (Windows). This 
works for text frames, too.

■■ To scale an image to fit inside a 
frame, you can choose Fit  
Content Proportionally or Fill 
Frame Proportionally from the 
Object > Fitting menu.

If the text frame is overset, you can 
click the out port with the Selec-
tion tool, and continue manually 
flowing text.

■■ To flow text semiautomatically, 
hold down Option (Mac OS) or 
Alt (Windows), and click a frame 
or empty area. Semiautoflow works 
like manual text flow, but the 
pointer becomes a loaded Place 
icon again after each click.

■■ To flow text automatically and gen-
erate new pages to hold all of the 
text, hold down the Shift key when 
you click. 

■■ To flow text automatically but 
not generate new pages, hold 
down Shift+Option (Mac OS) or 
Shift+Alt (Windows).

Importing graphics

If you already have a frame selected 
on your document page, you can 
import a graphic into it by choos-
ing File > Place. In the Place dialog 
box, select the graphic you want to 
import, select Replace Selected Item 
at the bottom of the Place dialog box, 
and then click Open.

If you have no frame selected on your 
page, or you deselect the Replace 
Selected Item option, when you 
click Open in the Place dialog box 
InDesign loads the Place icon . 
Then you can:

■■ Click an empty area of the page or 
pasteboard to create a new frame 
the size of the graphic, or click 
and drag the loaded graphics icon 
to create a frame the size of the 

Working with graphics and frames
■■ To specify default fitting options 
for a frame, use the controls in 
the Frame Fitting Options dialog 
box (Object > Fitting > Frame  
Fitting Options).
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When you choose more than one image in the Place dialog box (or drag more than one 
image into InDesign), you can place them one at a time. Note that the cursor tells you how 
many images are queued up: first three (left) and then, after clicking twice, one more (right).

action (Edit > Undo Place) to return 
to the loaded graphics icon. Then, 
either place the graphic again, press 
Esc to remove it from the Place icon, 
or click any tool in the Tools panel to 
clear the loaded icon entirely.

Alternatively, with more than one 
image loaded, you can press the 
arrow keys on your keyboard while 
you drag to place the images in a 
grid, similar to a contact sheet.

Copying graphics

In addition to importing native 
Illustrator files using the Place com-
mand, you can also drag and drop 
or copy and paste Illustrator vector 
artwork files into InDesign to work 
with them as editable objects. In this 
case, the artwork is no longer linked 
to the original Illustrator file. Some 
Illustrator features, such as gradient 

mesh, are not supported in InDesign, 
so this technique should be reserved 
for relatively simple artwork.

When you copy and paste, or drag 
and drop objects from Illustrator, 
they’re displayed in InDesign as 
a grouped collection of editable 
objects. If you want to work with the 
objects individually, select the group 
with the Selection tool, and then 
choose Object > Ungroup. 

Note that for copy and paste to work, 
the Copy As AICB option must be 
selected in the Illustrator Preferences 
dialog box, and Prefer PDF When 
Pasting must be deselected in the 
InDesign Preferences.

You can also copy objects from 
InDesign and paste them into Adobe 
Illustrator. However, text may be 
converted into outlines when you 
paste into Illustrator.

Although you can copy and paste 
pixel images from Photoshop into 
InDesign, it is not recommended. It 
is a better practice to use the Place 
command instead.

Display quality

InDesign offers several options for 
displaying graphics onscreen. By 
default, vector and bitmap images 
are displayed using low-resolu-
tion previews. To see better qual-
ity versions of your pictures, choose 

rectangle you drag. InDesign  
automatically scales the image to 
fill that frame.

■■ Click an empty frame to place the 
image into it.

Note that if a text insertion point is 
blinking when you place a graphic, 
the graphic is automatically placed 
as an anchored object that flows with 
the surrounding text.

You can select multiple files in the 
Place dialog box—including a mix 
of graphics and text files—and then 
place the files, in whatever order you 
want, into existing frames or into 
new frames. Press the arrow keys on 
your keyboard to step through the 
files loaded in the cursor icon.

If you don’t like the result after you 
place a graphic, you can undo the 
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You can customize the Links panel 
to show the information you want 
by choosing Panel Options from the 
panel menu. Here, a larger image 
thumbnail has been made visible in 
the File Info section, and the scale 
and resolution columns added to 
the list at the top.

View > Display Performance > High 
Quality Display. This may slow down 
screen redraw on your computer.

You can also increase the display 
quality of an individual graphic:

■■ Right-click (or Control-click with 
a one-button mouse in Mac OS) 
a graphic frame, and then choose 
Display Performance > High  
Quality Display.

■■ If you are importing an EPS file, 
select Show Import Options in the 
Place dialog box, and then choose 
Rasterize The PostScript to get a 
better quality preview.

Modifying placed graphics

To modify a placed graphic in its 
original application, hold down 
Option (Mac OS) or Alt (Windows), 
and double-click the graphics frame. 
(You can also select a graphic or its 
frame, and then choose Edit > Edit 
Original or click the Edit Original 
button  in the Links panel.)

The Edit Original feature relies on 
the Mac or Windows operating  
system to know what application to 
launch. You can also choose an  
alternate application from the Edit 
With menu (in the Edit menu or 
Links panel menu).

After you make and save your 
changes, the placed artwork is 
automatically updated in InDesign.

You can use the Links panel to 
identify, select, monitor, and relink 
imported graphics files. The Links 
panel displays a list of all imported 
graphics and a variety of link attri-
butes, including warning icons for 
graphics that have been modified 
or are missing.

Here are some other features in  
the Links panel that you should  
be aware of:

■■ You can reorder the files in the 
panel by clicking the name or 
icon at the top of the column. You 
can also change the order of the 
columns or change their width by 
dragging the column headers.

■■ Click the blue page number next 
to the filename to jump to that 
page and highlight the image.

■■ Click the triangle in the lower left 
corner of the panel to view the 
Link Info section, which offers 
more information about the 
selected graphic. For example, it 
can show bitmap image resolu-
tion, color space, current image 
scaling, and layer position.

■■ You can add or remove columns 
of information in the panel, or 
what information is displayed 
in Link Info, by choosing Panel 
Options from the panel menu.

The Links panel also lets you 
relink to a new file on disk, 
update modified links, reveal the 
file in Finder (Mac OS) or Explorer 
(Windows), copy the files to a 
new folder on disk (similar to 
Package, but for only selected 
files), and embed the placed file 
inside the InDesign document.

Links panel
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Using native file formats
The old QuarkXPress workflow 
required you to keep at least two 
versions of each graphic file: a  
layered, native Photoshop or  
Illustrator document as well as a 
flattened version, usually stored  
as a TIFF, JPEG, or EPS. 

InDesign supports these formats, 
but also lets you import native ver-
sions. Using the native Photoshop 
(PSD) and Illustrator (AI) file  
formats may significantly reduce 
your file-management overhead, 
save disk space, and streamline 
your workflow.

For example, you can place PSD 
files directly into your InDesign 
layouts. After placing a Photoshop 
image into a layout, you can mod-
ify it within InDesign by cropping or 
scaling it, or by turning layers and 
layer comps on or off. 

InDesign preserves transparency 
in Photoshop files, including soft 
edges. No matter what technique 
you use—paths, masks, or alpha 
channels—InDesign can read, dis-
play, and output the image.

InDesign even lets you place and 
separate PSD files that contain 3D 
artwork or spot colors, including 
duotone images.

You can also control the visibility 
of layers when you place PDF-com-
patible Illustrator (AI) files and lay-
ered PDF files. 

Select Show Import Options when 
placing native files to control how 
the files are imported. For example, 
when importing an AI or PDF file, 
the Import Options dialog box lets 
you choose which pages or art-
boards to place, whether to crop 
the artwork or include its bleed 
area, which layers you want vis-
ible, and whether the background 
should be considered transparent 
or opaque. 

When placing a native PSD file, the 
Import Options dialog box lets 
you choose which layers or layer 
comps to show, whether to apply 
an embedded clipping path, which 
ICC color profile to apply to the 
image, and even which channel to 

use as a transparency mask for the 
document.

If you’ve selected different layers 
or layer comps in placed PSD files 
in your layouts, be sure to let your 
printer know. Some printers flat-
ten PSD files as part of their work-
flow, which would not give you the 
results you want. Of course, this is 
irrelevant if you are sending PDF 
files to your printer.

Tip:
IMPORTING INDESIGN FILES

You can import native InDesign (INDD) 

documents into other InDesign files, 

eliminating the need for an intermedi-

ate PDF file. When you place an INDD 

file, InDesign treats it like a layered PDF 

document, so you can choose which 

page or pages to import, and you can 

turn on and off layers. When you pack-

age your document, all placed images 

and fonts in the original INDD file are 

also collected properly.
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You can choose one or more pages from a PDF or 
InDesign document by selecting Show Import 
Options in the Place dialog box (File > Place). You 
can also choose one or more artboards in 
Illustrator CS5 files that contain multiple 
artboards.

The import options dialog 
box also lets you adjust 
layer comp or layer 
visibility when importing 
a native Photoshop, 
Illustrator, InDesign, or 
PDF file.

The When Updating Link menu offers two options. Keep Layer 
Visibility Overrides will maintain any overrides you’ve made in 
InDesign if you edit the original file (unless the file’s layer 
structure is significantly changed). Use Photoshop’s Layer 
Visibility (or Use Document’s Layer Visibility) will reset any 
overrides you’ve made in InDesign when the link is updated. 

You can adjust layer comp or layer visibility after 
you select a graphic by choosing Object > Object 
Layer Options, and then adjusting the settings in 
the Object Layer Options dialog box.

The Link Info area of the Links 
panel displays the Layer 

Overrides status when you 
have changed the layer 

visibility for a graphic.

The preview image in the 
import options dialog box 
changes depending on the 

selected layer comp and 
the show/hide status of 

individual layers.
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Working with tables
You can easily create sophisticated tables in InDesign—making  
your own from scratch, converting imported text into tables, or placing styled 
Word and Excel tables. Tables can flow across multiple pages for easy editing 
and automatically include headers and footers. Extensive formatting options, 
including alternating fill and stroke controls, enable you to fine-tune the final 
design of your tables, and you can create table styles and cell styles to quickly 
and consistently format tables and cells.

In InDesign, tables are always 
anchored in a text frame. To cre-
ate a new table, select the Type tool, 
place the text cursor inside a frame 
or create a new text frame, and then 
choose Table > Insert Table. 

The Insert Table dialog box lets you 
specify the number of rows and col-
umns for your table. However, you 
can later make the table larger or 
smaller by placing the text cursor 
inside the table and using the options 
in the Table panel.

By default, the inserted table fills the 
width of the container text frame. If 
you make the frame smaller, the table 
remains visible outside the frame. 
Tables flow with surrounding text, 
just like anchored objects. Each cell 

in an InDesign table is similar to a 
text frame of its own, into which you 
can place text, graphics, and other 
tables. 

You can adjust each column width 
and row height in a table by dragging 
the dividers with the Type tool. 

Converting text to tables

InDesign provides a number of ways 
to turn text into tables and tables 
into text. For example, you can 
import tab-delimited text files from 
a spreadsheet or database, select the 
text with the Type tool, and choose 
Table > Convert Text To Table.

Importing tables

You can import a table from a 
Microsoft Word or Excel document 
like any other text file. Select Show 

Import Options as you import the 
data to fine-tune the imported data.

If you copy tabular data from Word 
or Excel, you can paste it into an 
InDesign table by placing the text 
cursor in the upper leftmost cell you 
want to populate, and then press-
ing Esc (to select the cell itself) and 
choosing Edit > Paste.

Threading tables

Because tables are anchored in 
text, InDesign lets you thread them 
across multiple text frames, making 
it easy to work with lengthy tabular 
information. You can set up running 
header and footer rows that appear 
at the top or bottom of the table on 
each page. To convert a normal row 
to a header row, select it with the 
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After you have formatted one table, you 
can save your table and cell formats in 
the Table Styles and Cell Styles panels.

To adjust a column’s width, drag the divider 
with the Type tool. To move a column 
without altering the overall table width, 
hold down the Shift key while dragging.

To format a row at a time, select all its cells 
by clicking along its left edge with the Type 
tool (or select a column by clicking along its 
top edge). You can then change all the 
selected cells at once using the Swatches, 
Stroke, Control, or Table panel.

To apply alternating tints and other 
table-wide formatting options, place 
the text cursor inside the table and 
choose Table > Table Options > 
Table Setup.

Flexible, powerful tables

You can easily convert this tab-delimited 
text into a table by choosing Table > 
Convert Text To Table.

To create a table in InDesign, choose Table > Insert Table 
with your text cursor in a text frame. Alternatively, you 
can import a formatted table or start with raw data.

Type tool, and then choose Table > 
Convert Rows > To Header.

Formatting tables

InDesign offers extensive format-
ting controls for tables. You can 
apply alternating fills or strokes by 
choosing Table > Table Options > 
Table Setup. You can specify cell 
inset values, alignment, text rotation, 
row height, column width, and keep 
options by choosing Table > Cell 
Options > Text. 

You can also format a cell, row, or 
column by selecting it with the Type 
tool and then using the Control, 
Stroke, Swatches, or Table panel.

InDesign makes it easy to add and 
delete rows and columns and to 
merge, unmerge, and split cells. You 
can find all these commands in the 
Table menu.

Table and cell styles

Creating table and cell styles is 
similar to creating paragraph and 
character styles. When you edit a 
table style or cell style, all tables 
or cells that have been format-
ted using that style are automati-
cally updated when you save your 
changes. You can create table and 
cell styles by opening the Cell Styles 
and Table Styles panels from the 
Window > Type & Tables menu.
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Using creative effects
InDesign includes transparency features that let you 
create eye‑catching, see-through effects that can be applied 
independently to an object’s fill, stroke, or content. These 
features include opacity, blending modes, and nondestructive 
Photoshop based effects to help you get exactly the results 
you want—as you design in real time with live preview. 

The Blending Mode and Opacity 
controls are in the Effects panel 
(Window > Effects), while all the 
other Photoshop effects are listed 
under the fx icon in the Effects panel 
or Control panel and in the Object 
menu (Object > Effects). Choosing 
an effect opens the Effects dialog box. 

You can apply transparency effects 
to any object, including text frames, 
placed graphics, and shapes that you 
create within InDesign. 

Here’s a list of the available effects 
and a description of the results they 
produce: 

■■ Blending Mode menu (Effects 
panel): Provides 16 options for 
changing the appearance of areas 
where the selected object or group 
overlaps underlying objects. 

The blending mode options in 
InDesign are similar to those in 
Photoshop and identical to those 
in Illustrator.

■■ Opacity field: Allows you to vary 
the degree of transparency of the 
selected object or group from 
100% (completely opaque) to 0% 
(completely transparent). When 
you decrease an object’s opacity, 
the object becomes lighter, and the 
underlying artwork becomes vis-
ible through the object.

■■ Drop Shadow: Adds a soft- or 
hard-edged shadow behind any 
object. You can control the posi-
tion of a drop shadow and vary 
the blending mode, opacity, size, 
spread, noise, and color of the 
drop shadow. The Use Global 
Light option lets you use the same 

position settings for all drop  
shadows in a document.

■■ Inner Shadow: Adds a shadow 
that falls just inside the edges of 
the object’s content, giving the 
object a recessed appearance.

■■ Outer Glow and Inner Glow: Add 
glows that emanate from the out-
side and inside edges of an object.

■■ Bevel And Emboss: Adds inner 
highlights and shadows that create 
a 3D relief effect.

■■ Satin: Adds interior shading that 
creates a satin-like finish.

■■ Basic Feather, Directional 
Feather, and Gradient Feather: 
Soften (or “mask”) the outer edges 
of an object by fading from opaque 
to transparent.
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Blending mode Transparency

Select Isolate Blending to restrict 
blending modes so they affect 

only the selected group. 

Transfer Photoshop effects by dragging the fx 
icon in the panel to another object attribute or 
on top of another object on the page.

Click here to clear all 
transparency and 

Photoshop effects 
applied to an object.

You can apply effects 
independently to a 
group, an object, its 
stroke, its fill, or to the 
text in text frames.

You can easily apply 
multiple effects at once 
using the Effects dialog box.

Select an object with the Selection 
or Direct Selection tool and then 
choose a Photoshop effect from 
this menu, the panel menu, or the 
Object > Effects menu. 

Tips:
WORKING WITH TRANSPARENCY

•	 Note that if you apply settings in the Effects dialog box without first selecting an 

object, each object you draw subsequently will have those new settings applied.

•	 To apply an effect to an image separately from its frame, first select it with the 

Direct Selection tool. While you cannot apply transparency effects to text selected 

with the Type tool, you can convert the text to outlines (Type > Create Outlines) 

and then apply the effect with the Selection tool.

•	 To learn more about transparency, visit www.adobe.com/print.
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The Highlight menu in the Flattener Preview 
panel provides several options for displaying 
specific instances of transparency, including 
Transparent Objects, All Affected Objects, 
and Outlined Text. For example, the 
Transparent Objects option highlights in red 
all transparent objects. 

Flattening transparency

When you print an InDesign file 
that contains transparent objects, 
InDesign performs a process called 
flattening, which converts all areas 
of transparency into a collection of 
opaque vector and raster objects that 
retains the appearance of the original 
objects. Flattening also occurs when 
you export a PDF file with Adobe 
Acrobat® 4 compatibility (such as a 
PDF/X-1a or PDF/X-3 file) or an EPS 
file, using File > Export.

You can choose the flattening quality 
in the Transparency Flattener area 
of the Advanced pane of the Print 
dialog box or the Export Adobe PDF 
dialog box. By default, the Preset 
menu includes three options: Low 
Resolution, Medium Resolution, and 
High Resolution. In general, Medium  
Resolution is appropriate for proof-
ing, and High Resolution should be 
used for all final output.

If you’re printing to a device that 
does not support Adobe PostScript®, 
or creating a PDF file that you will 
send to a client as a proof, you should 
check Simulate Overprint in the Out-
put pane of the Print dialog box. This 
way, the proof will look the same 
as it looks onscreen with Overprint 

Preview (View > Overprint Preview) 
enabled. This is especially important 
when using spot colors.

If none of the default presets meets 
the requirements of your printer—or 
your output provider’s printer—you 
can create custom flattener presets by 
choosing Edit > Transparency Flat-
tener Presets and then clicking New 
in the Transparency Flattener Presets 
dialog box. For information about 
creating flattener presets, refer to 
InDesign Help. 

Note that flattening is not neces-
sary when creating a PDF/X-4 file 
and printing to an Adobe PDF Print 
Engine RIP.

Managing transparency

In a document that will be flattened, 
it is a good practice to place text on a 
higher layer than transparent objects. 
This removes the chance that some 
text characters will become outlined 
in the flattening process.

The Flattener Preview panel (Win-
dow > Output > Flattener Preview) 
helps designers and printers prevent 
mistakes and helps ensure high-  
quality printed results by identifying 
transparent objects or objects that 
interact with transparent objects.
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In this original layout, the images and the text don’t 
stand out enough over the dark background.

Here, the graphic frames are given a 
beveled stroke with a small shadow 
to add dimensionality.

In the final layout, the Fill of the text 
frame is set to Paper, at 70% opacity. 

The text frame object itself is also 
given an angled Gradient Feather and 

a Pillow Emboss effect.

When you expect to apply the same 
object formatting more than once 
in a document, consider making 
an object style in the Object Styles 
panel. This lets you quickly apply 
and redefine your formatting. Your 
object style definition can include 
transparency effects applied to the 
object, its fill, its stroke, or (in the 
case of a text frame) its contents.

Adding creative effects to object styles
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When you open the Separations panel 
and choose View > Overprint 
Preview, InDesign displays a real-time 
ink reading of the area beneath your 
cursor. Click the visibility icons in the 
left column to hide or show individual 
color plates.

InDesign offers an array of options 
for outputting your projects, 
whether you plan to print your 
InDesign file or distribute it on the 
web, consumer electronic devices, 
or phones. However, before you 
export or print your document, use 
the InDesign preflight and proofing 
tools to help ensure the final result 
will appear as you expect.

To see an accurate view of what 
document pages will look like 
when printed or exported as PDF, 
choose View > Screen Mode >  
Preview (or press W when not edit-
ing text). This hides nonprinting 
page elements such as guides, the 
pasteboard, and frame edges. 

You can hide the InDesign user 
interface entirely, including menus 
and panels, by choosing View > 
Screen Mode > Presentation (or 
pressing Shift+W). This is a helpful 
display mode when showing a  
client or colleague your work.

If you choose View > Over-
print Preview, InDesign displays 
an onscreen “ink preview” that 

approximates how gradients, trans-
parency, and overprinting will 
appear in color-separated output.

The Separations Preview panel  
(Window > Output > Separations 
Preview) lets you visually check 
individual or multiple plates, pre-
view overprinting objects, and view 
ink-limit warnings onscreen before 
printing. 

The Preflight panel (Window > 
Output > Preflight) can warn you of 
problems that may prevent a docu-
ment or book from printing cor-
rectly. Preflighting is “live”—that is, 
when it is enabled, InDesign checks 
your document while you work, 
and displays a green or red dot in 
both the lower left corner of the 
panel and the document window. 

You can control what the Preflight 
panel considers an error by choos-
ing Define Profiles from the Pre-
flight panel menu. Options include 
minimum image resolution, color 
model limitations, document size, 
and more. After creating a new 
preflight profile, you can choose it 
from the Profile menu in the Pre-
flight panel.

Note that when you select an error, 
the Info area at the bottom of the 
panel provides more details.

If you are including interactive ele-
ments in your document, such as 
animations, you can see them in 
action inside the Preview panel 
(Window > Interactive > Preview). 

Preflight and proofing
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You can choose Define Profiles from 
the Preflight panel menu to tell 
InDesign what “errors” to look for.

The Preflight Profile menu lets 
you export or import profiles.

You can choose 
your profile here.

You can create a new 
Preflight Profile here.

You can double-click 
to jump to this object.

When a document has no 
errors, the “light” turns green.

This area identifies the problem 
and recommends a solution.
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Important techniques
The previous sections have helped you learn your way around 
Adobe InDesign CS5. Now it’s time for some techniques that will get 
you laying out pages faster and better than ever before. Whether you 
need to create colors and gradients, format text automatically, anchor 
an object inside a text flow, or just find some tips for getting more 
efficient with InDesign, you’ll find the answers in this section.

Selection tool techniques

The Selection tool and the Direct 
Selection tool are two of the most 
important tools in InDesign, so it’s 
helpful to know how to access them 
quickly. Here are some tips:

■■ You can temporarily access the 
Selection tool or Direct Selection 
tool (whichever was most recently 
selected) by pressing Command 
(Mac OS) or Ctrl (Windows) when 
any other tool is selected.

■■ When editing text with the Type 
tool, you can switch to the Selec-
tion tool by pressing the Esc key.

■■ You can double-click a text frame 
with the Selection tool or the 
Direct Selection tool to switch to 
the Type tool. If the text frame 
contains text, the blinking text 

insertion point is displayed where 
you double-click.

■■ Double-click a graphic frame with 
the Selection tool to select the 
graphic inside the frame. Double-
click again to reselect the frame.

■■ You can select “through” an 
object—selecting a frame or path 
behind another object—by holding 
down Command (Mac OS) or Ctrl 
(Windows) while clicking with the 
Selection tool.

■■ If you choose the Selection tool 
and then click any object that’s 
part of a group, the entire group 
is selected. To select an individual 
object that’s part of a group, dou-
ble-click the object with the Selec-
tion tool. Then press Esc to select 
the group again.
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Deselect All

Press Shift+Command+A (Mac 
OS) or Shift+Ctrl+A (Windows) 
to deselect all objects or text on a 
spread. It is particularly helpful to do 
this before creating or editing color 
swatches or editing a paragraph or 
character style, so that the swatch or 
style is not accidentally applied to the 
selected text or object.

Smart Guides

Smart Guides are temporary guides 
that appear as you create, move, 
rotate, resize, or scale an object or 
group of objects on your page. They 
help you lay out objects on a page 
quickly, without having to create 
guides and grids manually. 

You can turn Smart Guides on or 
off in the View > Grids & Guides 
menu, or by pressing Command+U 
(Mac OS) or Ctrl+U (Windows).

For example, if you want two objects 
to align along their left sides, you can 

enable Smart Guides, and then start 
dragging one of the objects with the 
Selection tool. When the sides or 
center points of the two objects are 
aligned, InDesign displays a light 
green guideline.

If you drag a third object near the 
first two, you will see a different kind 
of Smart Guide—one with arrows on 
each end—when the space between 
all three objects matches exactly.

If you rotate an object with the 
Rotate tool, InDesign shows the cur-
rent angle next to the cursor, and 
displays a green Smart Guide when 
the rotation matches the same angle 
as any other rotated object visible on 
the page.

Note that the Smart Guides feature 
“sees” only the objects that you can 
see at your current view. If you want 
Smart Guides to ignore an object, 
scroll the page so that you cannot see 
it, or place it on a hidden layer.

Gap tool

The Gap tool lets you adjust the 
space between objects. When you 
place the Gap tool cursor between 
two objects—or between an object 
and the side of the page—a light gray 
zone indicates which objects will 
be affected. By default, the Gap tool 
affects all objects with commonly 
aligned edges at the same time. 
Hold down the Shift key to limit the 
affected objects to those on either 
side of the cursor.

When you drag the Gap tool, the 
affected objects resize so that the 
space remains fixed. Hold down the 
Command (Mac OS) or Ctrl (Win-
dows) key while dragging to resize 
both the space and the objects. 

If you hold down Option (Mac OS) 
or Alt (Windows) while dragging, 
InDesign moves all affected objects 
instead of resizing them. 
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You can use 
the Gradient 
and Color 
panels to 
define a 
two-color 
gradient. 

Double-clicking the swatch in the 
Swatches panel opens the Gradient 
Options dialog box, where you can 
name or edit the swatch.

The Layers panel lets you manage objects 
in complex documents.

To add the gradient to 
the Swatches panel, 
choose New Gradient 
Swatch from the 
Swatches panel menu, 
or drag the swatch icon 
from the Gradient panel 
into the Swatches panel 
(shown here).

Working with layers

Each object sits on a layer inside 
your document. By default, every 
file has one layer, but you can add 
more layers in the Layers panel 
(Window > Layers). For example, in 
a complex publication, you may want 
four separate layers for images, text 
frames, background artwork, and 
interactive elements. To create a new 
layer, choose New Layer from the 
Layers panel menu.

When you select an object with the 
Selection tool, a square selection icon 
appears highlighted on the far right 
of the object’s current layer in the 
Layers panel. Drag the icon to move 
the selected object to a different layer.

When you click the triangle next 
to the layer name, the Layers panel 
reveals a list of all objects on that 
layer. To move an object—for 

example, to position it above or 
below other objects on the same 
layer, or to move it to a different 
layer—drag it up or down within the 
Layers panel. This technique also lets 
you move objects in or out of groups.

Clicking in the two columns along 
the left side of the Layers panel lets 
you hide/show or lock/unlock each 
object or layer. Double-click a layer 
to see more layer options.

New color swatches

By default, the Swatches panel con-
tains color swatches for the four 
process colors, plus process-color 
equivalents of red, green, and blue. 
To add a new color swatch, choose 
New Color Swatch from the panel 
menu, and then choose Process or 
Spot from the Color Type pop-
up menu. You can choose preset 
libraries of colors, such as Pantone® 
Solid Coated, from the Color Mode 
pop-up menu.

You can also create unnamed colors 
with the Color panel. You can then 
add those colors to the Swatches 
panel by choosing either Add To 
Swatches from the Color panel menu 
or Add Unnamed Colors from the 
Swatches panel menu.

Adobe Kuler™ is a web-hosted appli-
cation for generating color themes. 
You can download color swatches 
as well as create and edit your own 
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1. Double-click the 
Eyedropper tool to tell 

InDesign what formatting 
you want to copy. 

2. Click an object or text  
to “pick up” its formatting. 
If you change your mind, 
you can pick up different 
formatting by Option-
clicking (Mac OS) or 
Alt-clicking (Windows).

3. Click an object or drag over text to apply the formatting 
that was loaded in the Eyedropper tool.

color themes using the Kuler panel 
(Window > Extensions > Kuler).

Creating and applying gradients

There are several ways to define and 
apply a gradient from one color to 
another. You can apply a gradient to 
any selected object by opening the 
Gradient panel (Window > Color > 
Gradient) and clicking the gradient 
swatch icon. Then you can choose 
Linear or Radial from the Type pop-
up menu, adjust its angle, or reverse 
the gradient direction. 

To change the colors, click the  
gradient stops under the gradient 
bar, and choose a color in the Color 
panel. Alternatively, you can hold 
down Option (Mac OS) or Alt  
(Windows) and click a named color 
in the Swatches panel. To add new 
gradient stops, click a blank area 
below the gradient bar.

You can add the current gradient to 
the Swatches panel (or create a new 
named gradient) by choosing New 
Gradient Swatch from the Swatches 
panel menu. Named gradients do 
not include information about blend 
angle or location.

The Gradient Swatch tool lets you 
specify the start point, end point, and 
angle of a gradient. You can apply a 
gradient to the fill or stroke of any 
selected object or text.

Note that you cannot specify an 
opacity for a gradient stop. To create 
a gradient that changes from opaque 
to transparent, use the Gradient 
Feather tool or one of the Feather 
features in the Effects panel.

Copying formatting

The Eyedropper tool lets you copy 
character, paragraph, fill, stroke, 
and transparency attributes from 
any object, including an imported 
graphic. Double-clicking the 

Eyedropper tool displays the Eye-
dropper Options dialog box, which 
lets you specify the attributes the 
Eyedropper tool copies.

For example, you can set the current 
fill color by selecting the Fill icon in 
the Tools, Swatches, or Color panel 
and clicking a bitmap image with 
the Eyedropper tool. You can then 
save that color to the Swatches panel 
by choosing Add To Swatches from 
the Color panel menu. If you click a 
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You can apply a different corner effect to 
each corner of a rectangular frame. 

vector graphic with the Eyedropper 
tool, InDesign reads the RGB color 
from the screen preview.

To transfer text formatting from one 
range of text to another, select the 
Eyedropper tool, click the source text 
with the attributes you want to trans-
fer, and then click within a target 
paragraph, or drag the loaded Eye-
dropper icon over a range of text.

Converting RGB and spot 

colors to process colors

When working with spot colors, it’s 
a good idea to choose Ink Manager 
from the Swatches panel menu and 
then select the Use Standard Lab 
Values For Spots option. This helps 
ensure you get the best quality color 
for proofing and for conversion to 
CMYK. The Ink Manager also lets 
you convert a spot color to a pro-
cess color by clicking the spot color 
icon  to the left of the spot color 
name or by selecting the All Spots 
To Process option.

To convert RGB colors or images to 
CMYK when you print, choose Com-
posite CMYK, Separations, or In-RIP 
Separations from the Color pop-up 
menu in the Output pane of the Print 
dialog box.

You can convert to CMYK while 
exporting a PDF file by choosing 
Convert To Destination (Preserve 

Numbers) from the Color Conver-
sion pop-up menu in the Output 
pane of the Export Adobe PDF dialog 
box. Preserve Numbers indicates that 
images and swatches already defined 
with CMYK values will “pass through” 
and not be changed.

Drawing Bezier paths

While Adobe Illustrator is the indus-
try’s premier drawing application, 
InDesign offers many excellent draw-
ing features that work identically to 
those in Illustrator, including a Pen 
tool and a Convert Direction Point 
tool. Note that when the Pen tool is 
over a path, it automatically changes 
to the Add Anchor Point tool; when 
it’s over an anchor point, it changes 
to the Delete Anchor Point tool.

The Pathfinder panel (Window > 
Object & Layout > Pathfinder) lets 
you merge and intersect paths. The 
Object > Paths menu lets you com-
bine paths into compound paths.

You can also copy and paste editable 
vector artwork between InDesign 
and Illustrator (see “Copying graph-
ics” on page 24).

Redrawing frames with the Pencil tool

The Pencil tool lets you draw paths 
or frames free-form, by clicking and 
dragging. To create a closed path, 
hold down Option (Mac OS) or Alt 
(Windows) after you start drawing, 

and keep holding it down until you 
have released the mouse button.

The Pencil tool not only draws, it 
redraws: If you draw over part of a 
path or frame edge, InDesign deletes 
a section of the path and redraws 
using the new path you drew. This 
is helpful for converting rectangular 
frames into irregular shapes.

To change the Pencil tool’s tolerance 
settings, double-click the tool in the 
Tools panel.

Corner effects

You can make corners on any 
selected frame or path appear 
rounded (or one of several other 
corner effects) by choosing Object > 
Corner Options or selecting from the 
Corner Options pop-up menu  
in the Control panel.
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Select a frame with the Selection tool and 
paste it into a story with the Type tool to 
create an inline object. 

The Anchored Object Options dialog box lets you precisely adjust the position of an 
anchored object—whether it is inside or outside a text frame.

When working with rectangular 
frames, you can also change corner 
options by clicking the square yellow 
icon  that appears near the upper 
right corner of the selected frame. 
Then drag one of the diamond-
shaped yellow icons  on a corner 
to create rounded corners. Hold 
down Shift while dragging to change 
just that corner. Hold down both 
Shift and Option (Mac OS) or Shift 
and Alt (Windows) to change the 
corner type on a single corner.

Anchoring objects into text

When you copy a path, frame, or 
group with the Selection tool and 
then paste it into text with the Type 
tool, it’s called an anchored object. It 
behaves like a single text character 
that moves with the adjoining text as 
you make edits to the text. You can 
also create an anchored object by 
inserting the text cursor in text and 
choosing File > Place or Object > 
Anchored Object > Insert.

You can adjust the anchored object’s 
position by choosing Object > 
Anchored Object > Options. From 
the Position pop-up menu, choose 
either Inline or Above Line to place 
the anchored object within the text 
frame. Choose Custom to place the 
object inside or outside the frame.

When Prevent Manual Positioning 
is selected in the Anchored Object 
Options dialog box, you cannot drag 
an anchored object with the Selection 
tool. When this option isn’t selected, 
you can move an Inline or an Above 
Line anchored object vertically but 
not horizontally. However, you can 
drag a Custom anchored object in 
any direction. 

Use the Text Wrap panel options 
to control how text wraps around 
anchored objects. However, note 
that text wrap affects only the lines 
in a story after the one in which the 
object is anchored.

Converting text to outlines

You can convert text to outlines by 
selecting it with the Type tool and 
choosing Type > Create Outlines. 
The original text is replaced with a 
group of paths anchored in the text. 
If you hold down Option (Mac OS) 
or Alt (Windows) when selecting 
Create Outlines, the original text is 
preserved and the path group is not 
anchored.

You can also select one or more text 
frames with the Selection or Direct 
Selection tool and choose Create 
Outlines. This converts all the text 
in the frames, replacing the original 
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Converting text (top) to outlines (bottom) 
creates compound Bezier paths that can be 
manipulated or filled with an image.

frames. Hold down Option (Mac OS) 
or Alt (Windows) to create a copy, 
leaving the original frames.

When you convert text to outlines, 
some formatting may be lost, such 
as paragraph rules, underscores, 
and strikethroughs. Therefore, it is 
not a good practice to convert large 
amounts of text to outlines in your 
document. If you are sending a file 
to an output provider who does 
not have the necessary fonts, it is 
better to send them a PDF file, which 
embeds the necessary character 
outlines for printing.

Quick Apply

The Quick Apply feature lets you 
quickly find and apply character, 
paragraph, table, and object styles. 
It also allows you to choose features, 
such as menu commands and scripts, 
all while keeping your hands on the 
keyboard.

To open the Quick Apply panel, 
press Command+Return (Mac OS) 
or Ctrl+Enter (Windows). When 
the panel is displayed, type a few let-
ters of a style or menu item name to 
select it, and then press Return or 
Enter to apply it and close the panel. 
The letters do not need to be at the 
beginning of the name. For example, 
if you have a paragraph style named 
“Heading 1,” you can select it in the 
Quick Apply panel by typing “h1.”

You can control which features 
Quick Apply will list from the  
menu in the Quick Apply panel.

Nested Styles

InDesign offers several methods for 
automatically applying different text 
styles to different parts of a para-
graph. For example, you can apply 
unique formatting to a drop cap 
character by first creating a character 
style with the desired font, color, and 
so on. Then choose Drop Caps And 
Nested Styles from the Control panel 
menu, and select the new character 
style from the Drop Cap section.

The Drop Caps And Nested Styles 
dialog box (or, if you’re editing a 
paragraph style, the Drop Caps And 
Nested Styles pane of the Paragraph 
Style Options dialog box) lets you 
apply nested styles and line styles 
with even more control.

A nested style is a character style 
applied to a specified range of text 
inside the paragraph. For example, 
you can apply one character style to 
the first word of the paragraph, and 
another character style up to the first 
colon (:) character.

To create a nested style, you first 
create one or more character styles. 
Then, in the Drop Caps And Nested 
Styles pane of the Paragraph Styles 
Options dialog box, click New 
Nested Style. In the Nested Styles 
area, select a character style from the 
pop-up menu, and then click the area 
to the right of the character style, and 
choose Through or Up To. Choosing 
Through includes the character you 
specify in the rightmost column; 
choosing Up To formats only the text 
that precedes this character. Click in 
the rightmost column to type a 
character or view a pop-up menu of 
options. This setting determines 
where the character formatting ends. 

Below the Nested Styles section of 
the pane or dialog box, you can 
specify line styles, which let you 
apply character styles to specific lines 
in a paragraph. For example, you 
might create a character style that 
applies Small Caps formatting, and 
then use the Line Styles section to 
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To format the first 
paragraph of this 
story, place the text 
cursor in it and 
open Quick Apply. 
Type a few letters 
in the style name, 
and then press 
Return or Enter.

The paragraph style 
specifies the font 
and uppercase 
format. The nested 
line style applies 
bright blue to the 
first line. The 
nested style applies 
the darker blue to 
the first “word” (in 
this case, the 
number 17).

apply that character style to the first 
line of the paragraph.

Working with GREP

GREP is a set of codes that lets you 
define a text pattern—for instance, 
all words that begin with “a” and end 
with “e.” You can use GREP to search 
for and replace text based on patterns 
by choosing Edit > Find/Change 
and then clicking the GREP tab of the 
Find/Change dialog box. InDesign 
Help lists all the GREP codes; alter-
natively, you can choose from the 
options in the Special Characters For 
Search  menu in the dialog box.

If you want to save a Find/Change 
query, you can click the Save Query 

button, and then later recall it from 
the Query pop-up menu.

InDesign can also apply text styles 
to text inside a paragraph based on 
GREP patterns. You could use this fea-
ture, for example, to change the font 
or color of any text inside brackets in 
the paragraph.

To create a GREP style, choose GREP 
Styles from the Control panel menu 
(or the GREP Style pane of the Para-
graph Style Options dialog box, 
when you’re defining a paragraph 
style). Then click New GREP Style, 
choose a character style from the 
Apply Style pop-up menu (if you 
haven’t defined a character style yet, 

you can choose New Character Style 
from the pop-up menu), and type the 
GREP code into the To Text field.

Bullets and numbering

You can add bullets or sequential 
numbering to selected paragraphs by 
clicking the Paragraph Formatting 
Controls icon  in the Control panel 
and then clicking either the Bulleted 
List ( ) or Numbered List ( ) 
icon. To control formatting, styles, 
or positioning of the bullets or num-
bers, choose Bullets And Numbering 
from the Control panel menu.

You can apply automatic bullets 
or numbers as part of a paragraph 
style by choosing the Bullets And 
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Numbering pane of the Paragraph 
Style Options dialog box.

For more on bullets and numbering, 
including how to make multilevel 
lists and numbered lists across mul-
tiple nonthreaded text frames, see 
InDesign Help.

Placing text on a path

InDesign lets you place text along 
any path—even along the edge of 
a closed frame. After creating a 
path or frame, select the Type On 
A Path tool, which is paired with 
the Type tool in the Tools panel. 
Move the pointer over any posi-
tion on the path, and then click 
when the plus sign (+) appears. If 
you drag the pointer along the path, 
text flows along only the part of 
the path on which you dragged.

If you switch to the Selection tool, 
three bracket lines are displayed on 
the type path—one at each end and 
a shorter one at the midpoint. Drag 
these bracket lines to adjust the 
placement of type along the path. 
You will also see the in and out ports 
of the path, indicating that you can 
thread text to or from another path 
or another frame.

Choose Type > Type On A Path > 
Options to display the Path Type 
Options dialog box, which lets you 
control the placement of the type 
relative to the path.

Story Editor

InDesign provides the Story Editor 
(Edit > Edit In Story Editor), which 
offers built-in word processing sup-
port. The Story Editor is especially 
useful for working with small text, 
overset text, tables, and long stories 
that span several pages. You can view 
changes in the layout as you make 
them in the Story Editor.

You can customize how the Story 
Editor displays text by adjusting the 
settings in the Story Editor Display 
pane of the Preferences dialog box.

Note that if you use the keyboard 
shortcut Command+Y (Mac OS) or 
Ctrl+Y (Windows), InDesign toggles 
between the document window and 
the Story Editor window, matching 
the cursor position between the two 
windows.

Adding notes to text

You can add a note to any text story 
by placing the text cursor in the 
position you want the note, open-
ing the Notes panel (Window > 
Editorial > Notes), and clicking the 
New Note button in the panel. You 
can also convert any text to a note 
by selecting it and choosing Type > 
Notes > Convert To Note.

Notes are helpful when working with 
others in an editorial workgroup. 
You can see notes in the Story Editor 
or the Notes panel. They also appear 

in the document window as a small 
hourglass icon —move the cursor 
over the icon to see the note.

Anywhere you can type text, you can 
insert a note, including in a table. 
Notes can also be seen and created in 
Adobe InCopy (see “Supercharging 
your workflow” on page 54).

Creating conditional text

When you are creating two or more 
projects where most of the content 
is similar, it can be cumbersome to 
create, maintain, and store multiple 
files. Instead, you can create a single 
document that contains two or three 
different versions. You use the Con-
ditional Text panel to hide and show 
text for the areas that are different. 

For example, you can create a catalog 
with three different prices for each 
item, and assign each price a unique 
condition using the Conditional Text 
panel (Window > Type & Tables > 
Conditional Text). To print the cata-
log with the first set of prices, you 
would hide the other two conditions 
in the Conditional Text panel.

Once you create a condition in the 
Conditional Text panel, you can 
select any text and click the condi-
tion in the panel to assign it.

To assign a condition to an image or 
other nontext object, first make it an 
inline or anchored object.
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This story flows from the first column to the 
next in a multicolumn text frame.

After setting the first paragraph to Span All and the list 
paragraphs to Split 2, the text fits the frame much better.

Cross-references

One of the most time-consuming 
aspects of laying out a long docu-
ment—whether a book, a catalog, or 
a magazine—has traditionally been 
managing the cross-references. For 
example, if the text says “See Figure 
15-3 on page 36,” you would need to 
update the cross-reference if the  
figure or page number changes.

Fortunately, you can quickly create 
and update cross-references with the 
Cross-References panel (Window > 
Type & Tables > Cross-References).

To insert a cross-reference (some-
times called an “x-ref ”) at the current 
text cursor position, click the New 

Cross-Reference button  in the 
Cross-References panel. Later, if the 
cross-reference becomes out of date, 
you can refresh it by clicking the 
Update Cross-References button .

Span columns

When you create a multicolumn text 
frame (by choosing Object > Text 
Frame Options), text fits into each 
column. You can make a paragraph 
straddle two or more columns of a 
multicolumn text frame by choos-
ing a “span” option from the Span 
Columns  menu in the Control 
panel. You can also define column 
spanning as part of the definition of a 
paragraph style.

Conversely, you can select two or 
more paragraphs in a row and choose 
one of the “split” options from the 
Span Columns menu. This is helpful 
when setting a list of bulleted items.

Track changes

Keeping track of changes within a 
text story can be difficult, especially 
when there are multiple editors. 
InDesign makes it much easier with 
the Track Changes panel (Window > 
Editorial > Track Changes). To begin 
tracking, select a story and click the 
Track Changes  button in the 
panel. You can also choose Enable 
Tracking In All Stories from the 
panel menu.
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The Mini Bridge panel lets you manage your 
assets, including InDesign files, Illustrator 
graphics, Photoshop images, and text files.

Each edit to a story is tracked based 
on the name and color of the user 
(choose File > User). To view the 
edits, choose Edit > Edit In Story  
Editor. All additions are highlighted 
in the user color; deletions appear in 
both highlight and strikethrough.

You can accept or reject each change 
by placing your cursor in the text in 
the Story Editor window and clicking 
the Accept  or Reject  button in 
the Track Changes panel, or choosing 
from the Accept or Reject options in 
the panel menu.

Mini Bridge

Every InDesign user needs to man-
age graphics, text files, InDesign 
files, and other assets on disk. The 
Mini Bridge panel (Window > 
Mini Bridge) allows you to see your 
disk files inside a floating panel 
in InDesign. Note that the Adobe 
Bridge application must also be run-
ning to take full advantage of the 
Mini Bridge panel.

To find a file on disk, click the Search 
icon  in the Mini Bridge panel. 
Then you can place the file into your 
InDesign document by dragging it 
from the Content pane in the Mini 
Bridge panel to the document page. 

To preview a file before you place it, 
select it in the Mini Bridge panel and 
press the spacebar to make the image 
fill your screen. Press the spacebar 
again to return to your document.

Working with master pages

Although you can use master pages 
in InDesign the same way you use 
them in QuarkXPress, if you did, 
you’d be missing an opportunity to 
improve your efficiency. 

For example, you can base one mas-
ter page on another. Let’s say you 
are laying out a catalog that has five 
sections, each with a different back-
ground page color. You could put the 
objects that you want on all pages 
(page number, headers, and so on) 
on master page A, and then create 
five master pages based on that one—
each with a different colored back-
ground. When you need to make a 
change to all of the master pages (for 
example, changing the font for the 
headers), you would need to make 
the change only to master page A—
the other master pages would auto-
matically update. To base one master 
page on another, use the Based On 
Master pop-up menu when creating 
a master page, or select a master page 
and choose Master Options from the 
Pages panel menu.

You can apply a master page to more 
than one document page at a time 
by choosing Apply Master To Pages 
from the Pages panel menu. 

To copy a single master page from 
one document to another, make sure 
both document windows are visible 
at the same time. Then, make the 
document with the master page the 
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The original document contains dozens of 
frames with a gray background.

After clicking Change All, the targeted 
frames are converted.

The Object tab of the Find/Change dialog box 
lets you search for and replace any kind of 
object formatting. In this case, Find Object 
Format is set to the background fill color, and 
Change Object Format is set to apply a 
different fill color and a 1-point stroke.

active document, and drag the mas-
ter-page icon from the Pages panel to 
the other document window.

To copy all the master pages from 
one document to another, open the 
destination document as the active 
document, choose Load Master 
Pages from the Pages panel menu, 
and then select the document that 
contains the master pages.

Finding/changing object formatting

The Edit > Find/Change command 
lets you search for and replace not 
only text, but object formatting as 
well. The Object tab in the Find/
Change dialog box offers two fields: 
Find Object Format and Change 
Object format. Click inside these 
fields to edit them. For example, 
you can search for all objects that 

are filled with a yellow swatch and 
replace that fill with a red-to-white 
gradient swatch.

Rebuilding default preferences

InDesign stores information for 
plug-ins, features, and the appli-
cation itself in its preference files, 
such as the InDesign Defaults file. 
A damaged preference file can cause 
InDesign, or InDesign files, to 
behave erratically. You can recreate 
the preference files by holding down 
Shift+Option+Command+Control 
(Mac OS) or Shift+Alt+Ctrl (Win-
dows) when starting InDesign, and 
then click Yes when asked if you want 
to delete your preference files.

Rebuilding a document with IDML

After opening a QuarkXPress file 
(see “Opening QuarkXPress files” 

on page 17) or Adobe PageMaker® 
file in InDesign, it’s often helpful to 
rebuild the file via the IDML format. 
Choose File > Export, give the file 
a name, choose InDesign Markup 
(IDML) from the Format pop-up 
menu, and click Export. Then choose 
File > Open to open the IDML file 
you created. This rebuilds the file and 
strips out any corruption that came 
from the original document.

If you are not sure about the his-
tory of a file, hold down Command 
(Mac OS) or Ctrl (Windows) and 
choose About InDesign from the 
InDesign menu (Mac OS) or the 
Help menu (Windows). The Docu-
ment History section of the Adobe 
InDesign Component Information 
dialog box displays the background 
of the current file.
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Exporting PDF files
Adobe PDF has long been the backbone of the professional 
publishing workflow, allowing designers an easy method for sharing 
documents with printers, colleagues, and readers. The Adobe PDF 
format is strong yet flexible, suitable for both print and onscreen 
purposes. From its creation, Adobe InDesign was designed to 
import and export PDF files better than any other application. 

You can export a publication as a  
single PDF file directly from InDesign, 
without the need for Adobe Acrobat® 
Distiller®. This makes for easier and 
more consistent PDF creation, includ-
ing industry standards such as PDF/X.

To export an InDesign document as 
a PDF file, choose File > Export. If 
your document is destined primarily 
for print output, then choose Adobe 
PDF (Print) from the Format menu.

If your document contains interac-
tive elements, such as buttons, and 
imported SWF animations, choose 
Adobe PDF (Interactive) from the 
Format menu. 

To export a book or selected chapters 
in a book, choose Export Book To 
PDF from the book panel menu.

Print PDF

After you choose Adobe PDF (Print) 
from the Format menu and click 
OK, the Export Adobe PDF dialog 
box appears. The wide range of PDF 
export options may seem over-
whelming at first, but the built-in 
presets offer an easy way to create 
high-quality PDF files quickly. 

Choosing PDF/X-1a from the Adobe 
PDF Preset pop-up menu converts 
all colors to CMYK plus spot colors. 
Choosing PDF/X-3 maintains RGB 
colors in the file and includes color 
profiles. Both options result in all 
transparency being flattened. Use 
PDF/X-4 to maintain transparency for 
Adobe PDF Print Engine output.

If objects bleed off the side of your 
page, be sure that is accounted for 

in the Marks And Bleeds pane of the 
Export Adobe PDF dialog box. That 
pane also lets you place print marks 
(such as crop marks and page infor-
mation) around your page.

You can save the settings you make 
in this dialog box by clicking Save 
Preset. The presets you create can 
also be used in other Creative Suite 
applications. To create a PDF file 
based on a preset without seeing the 
dialog box, hold down the Shift key 
while choosing the preset from the 
File > Adobe PDF Presets menu.

Note that InDesign saves your PDF 
file in the background, so you can 
keep working. For large documents, 
you can view the export progress by 
choosing Window > Utilities > Back-
ground Tasks.
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You can navigate among the panes listed on the left side of the Print dialog box or the 
Export Adobe PDF dialog box by holding down Command (Mac OS) or Ctrl (Windows) 
and pressing numbers from one to seven.

When you choose PDF (Interactive) from the Format 
menu, the options are relevant for onscreen 
documents. Many of these options previously 
required editing your final exported PDF file with 
Adobe Acrobat Pro software.

If you prefer to create a PDF file using 
Acrobat Distiller, you can do that by 
choosing PostScript File from the 
Printer pop-up menu in the Print 
dialog box. After the PostScript file 
is saved to disk, you can open it in 
Acrobat Distiller. However, PDF files 
created with Acrobat Distiller do 
not support transparency, layers, or 
interactive elements.

Interactive PDF

When you choose Adobe PDF (Inter-
active) from the Format menu, 
InDesign offers a very different set 
of options, based on the assump-
tion that the final PDF will be viewed 
onscreen. Rich-media elements 
such as movies, animations, sound, 
hyperlinks, and bookmarks are 
included by default.

Note that page transitions and auto-
matic page turning are available in 
Acrobat only when the document is 
viewed in Full Screen Mode.

For more on interactive features, see 
“Rich, interactive documents” on the 
next page.

    Exporting PDF files  49



Buttons

You can add interactivity to your 
InDesign documents with features 
such as the Buttons panel, which lets 
you make rollovers and apply actions 
to your page objects. Choose Sample 
Buttons from the Buttons panel 
menu to view a set of predefined but-
tons you can use in your documents.

To create your own button, select any 
object—such as a text frame—and 
click the Convert Object To A Button 
icon  at the bottom of the Buttons 
panel. Then, choose an action from 
the Actions  menu in the panel, 
such as Go To Next Page.

Note that buttons, like all interactive 
elements, do not function on your 
InDesign page. Instead, you can view 
interactive content within InDesign 
by opening the Preview panel 

Rich, interactive documents
Publishers increasingly need to transform static page 
layouts into interactive documents that extend editorial content 
through the use of animation, embedded video, and sound. InDesign 
offers many tools for creating interactive documents. InDesign also 
tightly integrates with Adobe Flash Professional CS5 and Adobe 
Dreamweaver CS5, making cross-media publishing easier. 
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You can import 
movies or sound 

files into InDesign. 
The Media panel 

lets you apply 
controller skins, 

add navigation 
points, and define 

how the media 
appears in your 

final output.

The Preview 
panel displays 

your interactive 
document and 

lets you interact 
with it.

When you export a SWF 
file from InDesign, you 

can include the Page 
Curl effect. This lets the 

viewer drag pages as 
though turning a 

physical page.

Try it yourself by 
dragging the corners in  
the image on the right!

Bookmarks tab in Acrobat or Adobe 
Reader® software by using the Book-
marks panel (Window > Interac-
tive > Bookmarks) or by selecting the 
Create PDF Bookmarks option when 
generating your table of contents.

The Hyperlinks panel (Window > 
Interactive > Hyperlinks) lets you 
create both hyperlinks and hyper-
linked cross-references (see “Cross-
references” on page 45). To make 
a hyperlink, select text or an object, 
and then choose New Hyperlink 
from the Hyperlinks panel menu.

Movies and sound

You can easily import movies and 
sounds into your InDesign docu-
ments using File > Place. You can 
place video files in Flash Video for-
mat (FLV and F4V), H.264-encoded 
files (such as MP4), and SWF files. You 
can import audio files in MP3 format. 
Media file types such as QuickTime 
(MOV), AVI, and MPEG are supported 
in exported interactive PDF files but 
not in exported SWF or FLA files.

Once placed, you can use the Media 
panel (Window > Interactive > 
Media) to control how the movie or 
sound file will appear and play.

Animation

The Animation panel (Window > 
Interactive > Animation) lets you 
apply preset Flash animations to any 
object on your page. For example, 
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Exporting an EPUB file opens the Digital Editions Export Options 
dialog box, where you can control the styling of the final EPUB 
document.

An EPUB file appears differently depending on which device it is 
displayed on. Here, an EPUB file exported from InDesign appears  
in iBooks on an Apple iPad.

you can select a frame and choose 
Spin from the Preset pop-up menu in 
the Animation panel. When you view 
the page in the Preview panel, you 
will see that object spin around. The 
Animation panel offers a number of 
options for each motion preset. 

When you have multiple animations 
on a spread, you can use the Timing 
panel (Window > Interactive > Tim-
ing) to control the order in which 
they will play.

Animations you create with the 
Animation panel are included in 
exported SWF files, but do not work 
in PDF files. You can, however, place a 
SWF animation into an InDesign file, 
and export that as a PDF document.

HTML export

To export text and graphics for 
subsequent use in any HTML 

web-authoring application, choose 
File > Export For > Dreamweaver. 
Then you can specify what content 
is exported (Selection or Document) 
and the format in which it’s exported.

When you export to XHTML, all of 
your document’s InDesign para-
graph, character, and object styles 
are converted to CSS classes, so you 
can easily format the XHTML content 
using cascading style sheets.

EPUB

You can also export your file to the 
EPUB format, suitable for eBook 
readers such as Adobe Digital Edi-
tions or iBooks on the iPhone or 
iPad. To do this, choose File > Export 
For > EPUB. The Digital Editions 
Export Options dialog box lets you 
choose whether to base the EPUB file 
on XHTML or DTBook (an XML-based 

format from the Daisy Consortium 
that can help make content available 
for visually impaired people).

For best results, first use Layout > 
Table Of Contents Styles to define 
a list of sections in your document. 
Then choose that TOC style in the 
Digital Editions Export dialog box 
when exporting the EPUB file.

Note that many EPUB readers do not 
recognize embedded fonts, so you 
may choose to deselect that option.

You can also create an EPUB from a 
book panel by choosing Export Book 
to EPUB from the book panel menu. 
If you are using a TOC style, select 
Suppress Automatic Entries For 
Documents in the Digital Editions 
Export Options dialog box to avoid 
duplicate TOC entries.
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After opening the exported FLA file in Adobe Flash CS5 Professional, you’ll 
find the layout not only looks the same, but remains editable.

The original document displayed in InDesign.

To transfer one or more pages of your 
layout to Flash CS5 Professional, export 
using the FLA format.

If you need to build a more 
advanced interactive document, 
you can export your InDesign file in 
the Adobe CS5 Flash Professional 
(FLA) file format. This preserves the 
text, graphics, and layouts when 
the file is opened in Adobe Flash 
Professional CS5. 

From InDesign to Flash Professional

    Rich, interactive documents  53



Supercharging your workflow
In the fast-paced world of publishing, it’s essential that you find 
ways to optimize your workflow, whether you’re importing and formatting 
large amounts of text and graphics, working alongside editors, or 
collaborating with remote clients or colleagues. InDesign offers a number 
of features to help in these situations. Plus, InDesign is highly extensible 
and customizable through the use of plug-ins and scripts. InDesign is 
the hub of your workflow—taking some time to make that workflow 
efficient is an investment that will pay dividends for years to come.

Data Merge and XML

To maximize profitability, publishers 
must find the most efficient ways to 
extract and store content in a format 
that can be reused. InDesign lets 
you import data from a database in a 
number of ways.

The simplest method to import text 
and graphics from a database or 
spreadsheet is via the Data Merge 
panel (Window > Utilities > Data 
Merge). This lets you import tab- or 
comma-delimited text files into a 
template that you create.

For more complex data publishing, 
InDesign offers extensive support 
for XML. You can import, create, for-
mat, edit, and export XML files using 
an integrated toolset that includes 
a Structure pane for viewing and 
managing tagged content, a Tags 

panel (Window > Utilities > Tags) 
for applying XML tags to content, 
easy controls for mapping XML styles 
to text styles (and vice versa), and 
optional use of Document Type  
Definition (DTD) files for defining 
and validating XML structure.

You can also use scripting to generate 
and format InDesign pages based on 
imported XML, or apply an XSL trans-
formation (XSLT) when importing 
or exporting XML content to make 
it easier to flow XML into InDesign 
page templates or export it to a data-
base or website.

Share My Screen

When working with others in remote 
locations, you can choose File > 
Share My Screen to create a virtual 
room, based on Adobe ConnectNow 
(now directly accessible from within 

InDesign), where you and two other 
participants can share a screen; chat 
via text, audio, or video; or share col-
laborative whiteboards.

Adobe InCopy CS5

If you need powerful editorial col-
laboration capabilities, Adobe offers 
Adobe InCopy® CS5 software, a 
professional writing and editing pro-
gram that’s tightly integrated with 
InDesign CS5. 

The combined power of InCopy and 
InDesign lets editorial and design 
staff—whether offsite or on—work 
on the same file at the same time, 
without overwriting each other’s 
work. Designers retain complete con-
trol over the design, and writers and 
editors can produce or edit copy in 
the context of the layout. 
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A.	 Choose View > Structure > Show Structure 
to see the XML Structure pane. This lets you 
view a hierarchical outline of tagged 
document elements and imported XML 
content in your file. 

B.	 InDesign lets you start with a blank template 
or tag text and images already in a layout.

C.	 You can tag frames and 
content easily within the 
layout for import and 
export using the Tags 
panel (Window > 
Utilities > Tags).

D.	 Achieve the results you 
want on import through 
extensive XML import 
controls (File > Import 
XML), including the ability 
to link to XML files so you 
can update data quickly 
when the XML file 
changes.

A
B

C

Anything you can do in InDesign 
can be automated using a script. 
The Scripts panel displays a list of 
available scripts, including several 
samples you can use. Double-
click a script in the panel to 
launch the script.

Flexible publishing with XML

Plug-ins and scripts

Plug-ins and scripts add many func-
tional features to InDesign that can 
increase your efficiency. You can find 
about 20 sample scripts by choos-
ing Window > Utilities > Scripts, 
and then opening the Application > 
Samples > JavaScript folders inside 
the Scripts panel. These scripts add 
features such as the ability to sort 
paragraphs alphabetically, split a 
frame into a grid of smaller frames, 
and add crop and registration marks 
around any object on your page.

Virtually every aspect of InDesign 
is scriptable through standard 
scripting languages, including 
JavaScript for cross-platform script-
ing, AppleScript, and VBScript. 
For information on scripting, visit 
www.adobe.com/products/indesign/
scripting.

For additional information on XML, 
Adobe ConnectNow, or finding 
and using third-party plug-ins and 
scripts, see “InDesign CS5 resources” 
on the next page.
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The growing popularity of InDesign has created an extensive community 
of service providers, trainers, plug-in developers, system integrators, 
and others who provide support for InDesign users. Whether you’re in 
the process of preparing to switch to InDesign or you’re already up and 
running, you can tap into a broad range of helpful resources.

Support

■■ Adobe InDesign 
www.adobe.com/products/indesign 
Find links to product information, 
customer stories, reviews, awards, 
events, and InDesign related 
downloads, as well as support-  
and training-related links.

■■ Adobe Community Help  
http://community.adobe.com/help/
index.html  
Find answers to your InDesign and 
InCopy product questions through 
this online service.

■■ Adobe InDesign and InCopy Help 
and Support  
www.adobe.com/support/products/
indesign.html  
Find links to top support issues, 
tutorials, support-related 
announcements, and user forums.

■■ Adobe Forums 
www.adobe.com/support/forums 
Access links to user forums for 
all Adobe products, including 
InDesign and InCopy.

■■ Adobe Partner Finder  
http://partners.adobe.com 
Locate print service providers, 
trainers, and developers worldwide 
who support InDesign.

Training and tutorials

■■ InDesign How To  
www.adobe.com/products/ 
indesign/howto 
Learn about new InDesign features 
and more.

■■ Adobe TV 
http://tv.adobe.com 
Check out Adobe TV, a free 
online video resource for expert 
instruction and inspiration about 
InDesign and other Creative Suite 
products from Adobe.

■■ Adobe InDesign CS5 
Classroom in a Book®  
www.adobepress.com  
Quickly learn InDesign CS5 using 
a series of self-paced, project-
based lessons.

■■ lynda.com 
www.lynda.com 
Choose from hundreds of 
InDesign CS5 training videos in 
the lynda.com online training 
library.

■■ Total Training 
www.totaltraining.com 
Get up to speed quickly and  
easily with these comprehensive 
InDesign CS5 training videos.

■■ Kelby Training 
kelbytraining.com 
Watch movies or read articles by 
InDesign professionals on a wide 
variety of topics.

■■ Adobe InDesign Training 
www.adobe.com/support/training/
products/indesign.html 
Find a variety of training resources 
to meet your needs.

InDesign CS5 resources
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Third-party plug-ins

■■ InDesign CS5 and InCopy CS5 
third-party plug-ins 
www.adobe.com/products/plugins/
indesign 
www.adobe.com/products/plugins/
incopy 
Learn about third-party plug-ins 
available for InDesign CS5 and 
InCopy CS5.

Automation 

■■ InDesign CS5 scripting and XML 
www.adobe.com/products/ 
indesign/scripting 
Check out this online resource for 
information on automating pub-
lishing with InDesign using XML, 
IDML, and scripts.

■■ JDF-enabled workflow 
www.adobe.com/studio/print/pdfs/
JDF-WP_A9_updates_july08.pdf 
Check out this useful job ticket 
guide for JDF-enabled workflows.

InDesign Family

■■ Adobe InCopy CS5  
www.adobe.com/products/incopy 
Learn more about Adobe InCopy 
CS5 and using InDesign and 
InCopy together.

■■ InDesign CS5 Server  
www.adobe.com/products/
indesignserver 
Learn more about InDesign CS5 
Server and its role in the publish-
ing workflow.

Other resources

■■ Online bookstores 
http://isbn.nu  
Visit online bookstores to search 
for books about InDesign CS5.

■■ InDesign User Groups 
www.indesignusergroup.com 
Join one of the InDesign User 
Groups that have formed in  
major cities across the world.

■■ InDesign Magazine 
www.indesignmag.com 
Peruse InDesign Magazine, a 
bimonthly PDF periodical devoted 
entirely to InDesign and the  
growing community of InDesign 
professionals. Also, sign up for  
a free weekly InDesign tip!

■■ InDesignSecrets 
www.InDesignSecrets.com 
Keep up to date on the latest 
InDesign news with InDesign 
Secrets, an independent web-
site with expert podcasts, blogs, 
tutorials, and more. For tips on 
InCopy, try InCopy Secrets: www.
incopysecrets.com.

■■ Inside Adobe InDesign 
www.elijournals.com 
Go beyond the manual with each 
issue of Inside Adobe InDesign.

■■ Adobe Print Resource Center 
www.adobe.com/print 
Learn more about print publishing 
technology, printing documents 
that contain transparency, partner 
solutions, and Adobe products.

■■ Custom Editorial 		
Publishing Solutions  
www.adobe.com/products/indesign/
integrated 
Learn about layout and editorial 
publishing solutions built on top of 
core Adobe InDesign technology.

■■ Adobe Creative Suite 5 eSeminars 
www.adobe.com/events 
Register for free Creative Suite 5 
eSeminars and how to get the most 
out of InDesign CS5.

■■ Print and ePublishing Conference 
http://indesignsecretslive.com 
Plan to attend the next Print and 
ePublishing Conference or an 
InDesign seminar. These leading 
InDesign experts will show you 
their tips and techniques. 

■■ Adobe InDesign blogs 
and social media pages 
www.adobe.com/products/indesign/
blogs/ 
www.twitter.com/indesign 
www.facebook.com/indesign 
Explore InDesign blogs and other 
websites to learn the latest infor-
mation about InDesign CS5.

    InDesign CS5 resources  57

www.adobe.com/products/plugins/indesign
www.adobe.com/products/plugins/indesign
http://www.adobe.com/products/plugins/incopy
http://www.adobe.com/products/plugins/incopy
http://www.adobe.com/products/indesign/scripting
http://www.adobe.com/products/indesign/scripting
http://www.adobe.com/studio/print/pdfs/JDF-WP_A9_updates_july08.pdf
http://www.adobe.com/studio/print/pdfs/JDF-WP_A9_updates_july08.pdf
http://www.adobe.com/products/incopy
http://www.adobe.com/products/indesignserver
http://www.adobe.com/products/indesignserver
http://isbn.nu/twords/indesign%20cs5::0n
http://www.indesignusergroup.com
http://www.indesignmag.com
http://www.indesignsecrets.com
http://www.incopysecrets.com
http://www.incopysecrets.com
http://www.elijournals.com
http://www.adobe.com/print
http://www.adobe.com/products/indesign/integrated
http://www.adobe.com/products/indesign/integrated
http://www.adobe.com/events
http://indesignsecretslive.com
http://www.adobe.com/products/indesign/blogs/
http://www.adobe.com/products/indesign/blogs/
http://www.twitter.com/indesign
http://www.facebook.com/indesign


Index

10 reasons InDesign is better than 
QuarkXPress  6

Acrobat Distiller  50
Adobe Dreamweaver  52
Adobe Flash  52
Adobe Illustrator  26, 28
Adobe InCopy  56
Adobe PDF Print Engine  34
Adobe Photoshop  28
Anchored objects  43
Animation  53–54
Background color. See Fill
Bevel And Emboss  32
Bezier paths  42
Blending Mode  32
Blends  10, 41
Book files  20
Bookmarks  52
Boxes. See Frames
Bullets  45
Buttons  52
Character styles  19
Collect For Output  11
Color swatches  10, 40
Columns  20
Comments. See Notes
Conditional text  46
Content Grabber  16, 25
Content tool  8
Control panel  8
Convert text to outlines  43
Copying and pasting  24, 26
Corner effects  42

Cropping  25
Cross-references  47
Data Merge  56
Digital Editions  54
Distiller. See Acrobat Distiller
Document Layout palette. See Pages 

panel
Drop Shadow  32
Edit Original  27
EPUB  54
Exporting PDF files  50
Eyedropper tool  41
Feather  32
Fill  9, 15
Find Font  11
Fitting images  25
Flash. See SWF export
Flattening transparency  34
Flowing text  25
Font Usage  11
Frames  8, 12. See also Stroke
Gap tool  39
Get Picture/Get Text  9
Gradients  10, 41
GREP  45
Guides  16, 18
Hand tool  22
H&Js  10
HTML  54
Hyperlinks  52
Hyphenation  10
IDML files  11, 49
Illustrator. See Adobe Illustrator

Importing. See Place text and 
graphics

Import Options  28
InCopy. See Adobe InCopy
INDD files  28
Intent  20
Interactive documents  51, 52
Item tool  8
Justification  10
Keyboard shortcuts  13, 17
Kuler  40
Layered images  28
Leading  13
Lines  9
Linking text frames  10, 15
Links panel  11, 27
Magnification  22
Margins  20
Master pages  13, 48
Measurements palette  8
Microsoft Word files  24
Migration strategies  7
Mini Bridge  24, 48
Mixed ink swatch  11
Modify dialog box  12
Movie files  53
Navigating documents  22–23
Nested styles  44
New Document  20
Normal style  11
No Style  11
Notes  46
Numbering  45
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Object styles  19
Opacity. See Transparency effects
Overprint Preview  36
Overset text  15
Package  11
Pages panel  9
Panning  22
Paper  10
Paragraph styles  11
Pathfinder  42
Paths  9
PDF files  50–51
Pencil tool  42
Pen tool  42
Picture Usage  11
Place text and graphics  9, 24–27
Plug-ins  11, 57, 59
Polygons  9
Power Zoom  22
Preferences  49
Preflight panel  36
Presentation mode  36
Preview mode  36
PSD files  28
QuarkXPress files  19
Quick Apply  44
Resizing  16, 25
Resources  58
Rotate Spread View  20
Rounded corners  42
Runaround. See Text Wrap
Save backward  11
Scaling images  25

Scripting  57
Selection tools  8, 16, 38–39
Separations Preview  36
Share My Screen  56
Shortcuts  17
Smart Guides  18, 39
Sound files  53
Span Columns  47
Spot colors  11, 40, 42
Starbursts  9
Story Editor  46
Stroke  10, 15
Styles  11, 19
Swatches panel  10, 40
Table of Contents  52, 54
Tables  10, 30–31
Tags panel  57
Text Frame Options  12, 47
Text on a path  46
Text Wrap  10, 18, 43
Threading text frames  10, 15
Tools panel  13
Track Changes  47–48
Training and tutorials  7, 58
Transparency effects  32–34
Usage dialog box  11
White  10
Workspaces  14
XHTML  54
XML  56
X-refs  47
XTensions. See Plug-ins
Zooming  22
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